Sign-in / Sign-up
Your question
Solved

Upgraded graphics - pc turns on but nothing boots up; black screen

Tags:
  • Graphics Cards
  • Graphics
  • Boot
Last response: in Graphics Cards
June 15, 2014 10:00:15 PM

I recently upgrade my graphics card from a HD5770 to a R9 270. When I plug everything in and turn on the PC, everything starts running but does not boot anything. However, when I tried it on another computer it would run and everything would boot up. The first build is with an i5 2500k with p67a-c43 b3 motherboard and the second is with an intel duo core. Both using a 650W psu.

More about : upgraded graphics turns boots black screen

a b U Graphics card
June 15, 2014 10:03:25 PM

maybe there is a comnpatibility issue. Try to update your MB BIOS to the latest version (if you havent done it already). If you did that allready, try to reset your BIOS (steps are in your MB manual)
m
0
l
a b U Graphics card
June 15, 2014 10:07:50 PM

Hmm seems like a power supply issues to me. Not 100% sure, but I would double check your PCI-e power connections on the first build w/the GPU installed.

Which PSU are you using? Make/Model please.
m
0
l
Related resources
June 15, 2014 10:24:10 PM

Antec Truepower 650C
m
0
l

Best solution

a b U Graphics card
June 15, 2014 10:35:58 PM

I would make sure all of your Mobo drivers and BIOS are up to date, to rule out any issues there.
Share
a b U Graphics card
June 15, 2014 10:36:05 PM

Try to use the same PSU to eliminate the problem :) 
m
0
l
June 15, 2014 11:27:19 PM

Had to update all MB drivers and BIOS. BIOS was behind at ver 1.C and needed to be upgraded to ver 1.J
m
0
l
a b U Graphics card
June 15, 2014 11:44:50 PM

fung604 said:
Had to update all MB drivers and BIOS. BIOS was behind at ver 1.C and needed to be upgraded to ver 1.J


So are you running well now?
m
0
l
June 17, 2014 12:10:57 PM

Yeah everything runs perfect now. Thank you all.
m
0
l
a b U Graphics card
June 17, 2014 5:20:03 PM

Glad that we could help :) 
m
0
l