Solved

Compaq presario 5123 hangs at boot

When I turn it on
it checks disk for errors
then asks for date and time
Then hangs..

I've tried loading xp and windows 7 but it says no operating system found
5 answers Last reply Best Answer
More about compaq presario 5123 hangs boot
  1. Best answer
    First thing you'll want to do here is replace the CMOS battery - the system not keeping time is usually related to that battery going bad (it's what lets the computer keep time when power is off). I could not find any disassembly instructions for the model you list but you will need to get inside to swap out that battery (it is a small button battery).
    Could be that replacing the battery cures all your issues, even if not, that's where to start
  2. Bump
  3. I replaced the battery but same results and sorry the model number is 5123sr
  4. You are referring to the CMOS battery and not the main battery, correct? Did it take care of the "set clock" message? If the set system clock message is still appearing, I'll suggest trying a different battery for the CMOS since, at a minimum, that message should go away once the clock is set with a fresh battery - either that or your BIOS is corrupted, let's hope that isn't the case here
  5. Thx for.your help and consistency but I tried to burn windows xp in a cd-r this time and it's installing now but thank you

    P.s. I did get into the bios and change the boot order to boot from cd drive and that when it said no operating system found
Ask a new question

Read More

Presario Boot Compaq Computers