Sign in with
Sign up | Sign in
Your question
Solved

ASUS Z87_pro V edition and core i7 4770k problem

Last response: in Components
Share
June 18, 2014 12:53:56 PM

hello,

today I've received said mobo and processor and immediately run into problems. I got blinking led lights for CPU and DRAM. I know that there are tons of similar threads but none exactly as my case.

I assembled everything by the book (manual), made sure I touched everything by the edges, discharged static and such. installation went without problems, but when I powered the machine I got those blinking lights and no POST screen. so, following other threads i took everything apart and checked cpu pins but everything looked fine, no bent ones for what I could see. by plugging in parts one by one I narrowed it down to RAM chips. namely, when unplugged there's no blinking light for CPU and for RAM it stays on the whole time, diagnostics display says 53 (but I guess it's ok since there's no RAM plugged in). as soon as I plug in RAM leds start blinking again. I tried plugging one then the other in every slot but it's the same.

what's different in my case is that MemOK button turns off the pc the moment I press it. codes on the diagnostics display are 13, 15, 21, 36 and 4F, and they run in circles. according to manual I guess that's normal process since those are not error codes, but system check ones, and they run in circles.

so my guess is that it's not mobo that's faulty since diagnostics run fine, all fans are turning and it all points to bad ram chips. but what bugs me is why MemOK turns the pc off? could it be I pressed ram chips to hard when plugging them in and something broke? why no CPU led blink when there's no RAM plugged in?

any help appreciated! thx...

ASUS Z87-Pro (V edition)
Intel core i7 4770k, not overclocked, had not time to do it, ;-)
2x4GB Kingston KVR16N11/4 (compatible, according to manual)
June 18, 2014 12:58:14 PM

Clear the CMOS using the jumper on the motherboard. If that doesn't work, try the BIOS_FLSHBK button. Let me know :) 
m
0
l
June 18, 2014 1:22:26 PM

thanks, mate. I did try that too. clearing CMOS did nothing, pressing BIOS_FLSHBK made green led light by the button flash few times then it stayed green until I powered up the pc. doing that while pc was on did nothing. no joy... :-(
m
0
l
Related resources
June 18, 2014 1:25:48 PM

I find it hard to believe both sticks in the same kit would be bad unless damaged in shipping or something. It could be the DIMM slots are bad on the motherboard too.

You don't happen to have other DDR3 sticks you can try do you?
m
0
l
June 18, 2014 1:35:06 PM

sadly no. my old wreck used DDR2. I just hope I didn't break something when pushing them in, or it will be bye bye warranty... damn!
m
0
l

Best solution

June 18, 2014 1:40:05 PM

I doubt you did, ASUS makes pretty sturdy boards, and it takes a lot to break one lol if no one else has any suggestions, you might just get in touch with ASUS for an RMA, their customer service is outstanding.
Share
June 18, 2014 1:48:14 PM

thank you for trying. I'll definitely do that since I tried everything else I could find. cheers! ;-)
m
0
l
!