Sign-in / Sign-up
Your question
Solved

Insatlled OS on my new built computer. Everything went fine but it cannot connect to the internet. Please help

Tags:
  • Routers
  • Computers
  • Connection
  • Ethernet Card
  • Systems
  • Internet
Last response: in Systems
June 18, 2014 2:49:24 PM

I moved the router to my room so I could get an ethernet cable to reach and plugged the ethernet from the router to the back side of my motherboard but it still says no connection are avabiable.

What to do? Please help

More about : insatlled built computer fine connect internet

Best solution

June 18, 2014 2:55:17 PM

You need to install the driver for your motherboard or network card
Share
June 18, 2014 2:59:49 PM

Oh right. I wondered how to do that but then I thought that they would probably be on the motherboard CD right? I put that in and I think I installed em'

Let's see if this works and thank you <3
m
0
l
Related resources
June 18, 2014 3:01:14 PM

Don't forget a free antivirus :D 
m
0
l
June 18, 2014 3:09:35 PM

Haha will not thanks man it installed the LAN driver and now it connected! Now it's installing all these other drivers that I don't even know what they mean xd

I'm guessing I should probably put the CD that came in with my GTX graphics card after this as well?

Will it have some helpful drivers or w/e? :p 

And thank you very much sir
m
0
l
June 18, 2014 3:13:22 PM

nzae said:
Haha will not thanks man it installed the LAN driver and now it connected! Now it's installing all these other drivers that I don't even know what they mean xd

I'm guessing I should probably put the CD that came in with my GTX graphics card after this as well?

Will it have some helpful drivers or w/e? :p 

And thank you very much sir


Do not install the disk that came with your GTX card, it is very outdated. Goto, http://www.geforce.com/geforce-experience
and download geforce experience. It will automatically scan for your card and give you the updated driver for you card.
m
0
l
June 18, 2014 3:15:09 PM

Oh.
Wow thanks for the save man... Good thing my motherboard disk had lots of stuff to install
m
0
l
June 18, 2014 3:21:09 PM

nzae said:
Oh.
Wow thanks for the save man... Good thing my motherboard disk had lots of stuff to install



What is your MOBO, I could help you find the updated drivers aswell for that if you would like. (Hint): Almost never install the drivers that come on CDs with your products,(unless completely unavoidable) always google your product and then simply put "drivers" after it, it will 99% of the time bring you to the manufacturers website for all the updated drivers. Nothing bad will happen if you install the drivers from the disk, they will just not work aswell for most things as the newer ones.
m
0
l