Sign-in / Sign-up
Your question
Solved

Can't go into BIOS/UEFI

Tags:
  • Go
  • BIOS
  • Systems
Last response: in Systems
June 21, 2014 5:56:38 AM

Hi,Like the title says i can perfectly boot into windows but when i try to go into UEFI/BIOS it gets stuck


MOBO: MSI Z87 G41
CPU:i5 4670k
RAM:GSKILL RIPJAWS X 8 GB
OS:WINDOWS 7 PRO
GPU:r9 280X

More about : bios uefi

June 21, 2014 12:12:40 PM

What do you mean by "stuck"? What happens from the time you start tapping the DEL key?
m
0
l
June 21, 2014 12:47:36 PM

It just goes to a black screen until i reboot.
m
0
l
Related resources
June 21, 2014 12:57:47 PM

Have you tried doing a BIOS reset?
m
0
l
June 21, 2014 7:36:16 PM

I did and still gets the black screen
m
0
l
June 21, 2014 8:31:01 PM

It may be a corrupted BIOS. Before assuming so however, try disconnecting all the drives, remove the gfx card and connect the monitor to the MB video port. Remove anything in the USB ports other than the keyboard. (you may even want to disconnect all the FP wiring except for the power button pair.) This will be a bit like breadboarding the MB.

Then try booting to BIOS and see if it works. If it is still a fail, and resetting the BIOS with the CLR_CMOS jumper (and pulling the battery) doesn't help*... I'd have to consider a corrupted BIOS. At that point you'll have to make a decision if you want to try to update/repair it via MSI's Live Update in Windows.

*page 1-29 in MB manual
m
0
l
June 21, 2014 8:38:25 PM

I've never flashed BIOS,does it reformat windows or anything?
m
0
l

Best solution

June 21, 2014 9:10:05 PM

FenrirCrow said:
I've never flashed BIOS,does it reformat windows or anything?


No, no. The BIOS has nothing to do with Windows or your HDD. It is the chip that provides your MB with the ability to start up on its own. The BIOS itself is apparently OK. But the entry point of the BIOS pgm doesn't seem to work. Flashing the BIOS is a last resort. It is simple to do with Windows. But if done wrong, your MB is toast.

You can also flash the BIOS from within BIOS. But obviously you can't do it that way. The Live Update pgm runs in the Windows environment and checks to see if you need an update. You can install it from your MB disk* and check it out. See if it is something you are comfortable doing. It's basically all automatic. It goes online and finds your version of BIOS, downloads it and asks if you want to install it. Then it will reboot and start the EEPROM flash which must not be interupted!

The other option is to live with it the way it is or until a solution presents itself. Updating the BIOS was just a suggestion on my part. No guarantees. Did you do the CMOS jumper/battery reset already?

* better yet, get the latest version of the pgm here for the OS you are running: http://us.msi.com/product/mb/Z87G41_PC_Mate.html#/?div=...
Share
June 21, 2014 11:51:37 PM

Yeah i tried resetting the CMOS using the jumper and removing the battery too,guess ill bring it to a technician to fully grasp what's the problem.
m
0
l