Sign in with
Sign up | Sign in
Your question

Graphic Card Fan spins but no display?

Last response: in Graphics & Displays
Share
June 23, 2014 4:05:14 AM

Hi I bought Nvidia GTX650Ti and 600w PSU also +4GB RAM
My first Graphic card was Nividia GT630 and PSU was 320w.
I replaced PSU and Graphic card but it says no signal and I can't even open bios screen. But Graphic Card fan spins?
a b U Graphics card
June 23, 2014 4:09:54 AM

Jaquellz said:
Hi I bought Nvidia GTX650Ti and 600w PSU also +4GB RAM
My first Graphic card was Nividia GT630 and PSU was 320w.
I replaced PSU and Graphic card but it says no signal and I can't even open bios screen. But Graphic Card fan spins?


That should be a nice upgrade for you. Just need to check - you did plug in the additional 6 pin power cable for the 650ti right?
m
0
l
a c 79 U Graphics card
June 23, 2014 4:17:32 AM

Also check that its in the top (nearest to cpu) pcie slot and that its in fully and locked in.

Make sure you have the cable to the monitor connected in the right ports in the monitor and graphics card. Check your cable is OK - try it in another pc.

What make and model power supply have you got?
m
0
l
Related resources
June 23, 2014 4:23:43 AM

Yes I plugged and I bought high-power 600w eco
m
0
l
a b U Graphics card
June 23, 2014 4:31:52 AM

Jaquellz said:
Yes I plugged and I bought high-power 600w eco


You mentioned you put in a new PSU, so what about all the other cables? e.g. a loose 12v cpu power cable would cause the issues you're describing
m
0
l
a c 79 U Graphics card
June 23, 2014 4:36:15 AM

What make is that psu?
m
0
l
a c 79 U Graphics card
June 23, 2014 5:17:37 AM

Its got 2 12v rails each at 20A max. The GTX 650Ti will need all that 20A. You should get a single rail power supply.
m
0
l
a b U Graphics card
June 23, 2014 5:19:56 AM

Make sure your display is plugged into the video card, and not the motherboard. That sounds like the issue here. If you have a video card installed the onboard video does not work at all, and the graphics card will only display an image if you have the display plugged into it directly.
m
0
l
!