Solved

Asus Maximus VII Ranger mobo compatible with CT120M500SSD4 (Crucial M500 120GB M.2 Internal SSD)?

So I have just powered up my new build......

CPU - I7-4790k
MOBO - ASUS Maximus VII Ranger
GPU - *Integrated GFX at the moment*
MEM - 2x4gb Hyperx Fury Red 1866
COOLING - Custom WC loop
STORAGE - 120gb Kingston SSDnowV300 + 120gb Crucial M500 M.2 Internal SSD CT120M500SSD4

Everything is working wonderfully except for one thing...... the M.2 M500 SSD..... :no:

Nothing..... Zilch....:??:
Not detected, nothing...... in windows or bios....

There isnt a whole lot of info in the manual regarding M.2 except for a description of the key and socket on page 1-47
and under section 3.6.7 Onboard Devices Configuration on page 3-37.

When I found this section in the bios I thought i found the problem... unfortunately M.2 Mode was already selected :pt1cable:

Any help would be greatly appreciated, the only thing left I can think of is I got the wrong ssd or its DOA?

Images to help.....
http://s27.postimg.org/6d2eg1fxf/DSC_0035.jpg


16 answers Last reply Best Answer
More about asus maximus vii ranger mobo compatible ct120m500ssd4 crucial m500 120gb internal ssd
  1. Is the BIOS set at "M.2 mode?" Try the other/different settings and see.
  2. "m.2" mode appears to be the only setting that enables the m.2 connector.... I have tried the other settings too though, thank you for your reply.
  3. Have you checked in disk manager to see if it is there to be initialized?
  4. Disk management shows only the boot ssd there is no entry for the m.2 ssd, tried re-scanning etc
  5. Best answer
    Try a third party app like Partition Wizard and see if the Part Wiz picks up the M.2. Should be able to do a quick format and give it a letter so windows can see it. If no luck there, I'd RMA the M.2. If another one has the same problem you can pretty much be sure that the MB has a problem with the M.2 circuitry.

    You could try re-seeding the M2 making sure that it is in tight and correct.

    Customer Service and Technical Support
    For technical support, customer service or returns, contact us
    using your preferred method below.
    North and South America
    Email: crucsupport@micron.com
    Phone: (208) 363-5790
    Toll free phone: 1 (800) 336-8915 (US and Canada only)
  6. One more thing to check. Look in device manager and see if there is a yellow marker on any devices there. If so load the correct drivers. Good luck...
  7. Just installed partition wizard and like disk management in windows, shows only the boot ssd.
    So it does indeed appear to be a dead ssd or dead M.2 circuit in mobo......
    So next step would be rma the Crucial M500? Agree?
    (thanks for the mailing address by the way)
    *Device manager shows no problem devices...and heading to the firmware link now........
  8. As I feared bacause the M500 is not 'detected' the firmware util just throws a 'no ssd to update' error.
    Thank you for your help Spooky2th, looks like a RMA of the ssd day and HOPEFULLY its that and not the mobo ;)
  9. I'd guess it's more than likely the ssd.
  10. I now have the same problem as listed above (drive just not recognized) using a Kingston M.2 120GB SSD and an Asus Ranger (latest BIOS 1.3), from what I can see of it Asus have an issue with M.2 recognition!? Thoughts...
  11. Maybe leigh76, will post his results. If second M.2 ssd is not seen/recognized then it probably is an asus issue. Board or software?
  12. spooky2th said:
    Maybe leigh76, will post his results. If second M.2 ssd is not seen/recognized then it probably is an asus issue. Board or software?


    Thanks for getting back to me, I think I now have the answer! It appears that the Asus Ranger ONLY supports M.2 PCIe and not M.2 SATA and it is an M.2 SATA device that I have (SM2280S3/120G). Seems odd though as all of the other manufacturers MSI , Gigabyte and ASRock support both standards! Also the Asus motherboard manual is very unclear on this, with just a small section near the front of the manual giving away its lack of M.2 SATA support. Hope this helps some others... ;-)
  13. Hi all, I am also using an Asus motherboard Maximus Vll hero, inserted the Crucial M550 512gb m.2 ssd but also not recognised. Spoke with crucial who said this SSD is not compatible with motherboard, but couldn't tell me why. Awaiting answer from Asus tech support by email. It seems like JCCrewe has the answer and I agree Asus have little detail on this M.2 slot, If I had known this was not supported I may have opted for a different board.
  14. The diagram here specifically says that that is an M.2 slot at the center of the board.

    http://www.asus.com/Motherboards/MAXIMUS_VII_RANGER/

    I think that Asus maybe was in a rush to get the board out there on time with the rest of the manufacturers, but didn't have the technology down pat yet.

    1 x M.2 Socket 3, with M Key, type 2260/2280 storage devices support (PCIE mode)

    Type 2260 or 2280
  15. I just bought one of these boards.
    The M.2 slot is only PCIE. I just spent a couple of days installing my SAMSUNG XP941 256GB M.2 PCI-EXPRESS drive and loading windows 7.
    When purchasing a new drive it looks like it needs to be PCIE x4 to make it worth doing over PCIE x2 (like one of the Plextor M.2 PCIE models) or M.2 SATA (which won't work on this board).
    I know this is an old thread but I found the easiest way to install windows 7 also if anyone is interested.
    I think they left the M.2 SATA support off because it's reached it's speed limit and it doesn't have any real benefit over a standard SSD apart from it's form factor. Maybe they could have supplied both so you can re-use your old drive but I guess they are going for the new faster standard.
Ask a new question

Read More

4790k Storage M.2 Crucial Maximus VII Ranger Asus SSD Crucial M500 Compatibility New Build