ASUS P8P67 Pro DRAM

So, I started up my PC this morning and everything booted fine. Sometimes when I start up the PC it would restart a few times, and recently I've gotten a message from the Bio's saying it couldn't OC properly. Today when I booted up everything was fine except my mouse (Logitech g9x) wouldn't power. No LED's.

I did a hard restart and it turned on for a minute or two then didn't. So after 1 or two hard restarts and the same thing no matter what USB port I used(even tried the USB port that my keyboard which was working was in) the mouse wouldn't power.

I did one more hard restart and now my keyboard AND mouse have no power. So I start to assume my MOBO may be going, and I did a final hard restart and boom, DRAM.

I've reset the CMOS with the jumper, and with the battery being out for an hour. I've tried with only one stick of ram, I run 3 sticks at 8GB each(4th slot is blocked by my thermaltake T.F.B. heatsink) I've tried each stick in each slot by themselves. No luck.

I have pressed MemOK! but I have no idea what it does or how to read the results.

MOBO: asus p8p67 pro
CPU: 3rd gen i5
GPU: Radeon HD 6950
PSU: Corsair TX650
RAM: 3x8gb gskill ripjaw x


At this point I'm assuming my MOBO is dead. I contacted ASUS support and they are awful and want me to wait for 6 days before a MOBO even gets shipped to me for a replacement, if it's even under warranty, they can't check until they receive it back and I'll just get charged for the same MOBO if it isn't.


Is it safe bet that I will need a new MOBO? Anything more I could do?

Edit: Tried the G9X is my laptop too, it won't power. Is it possible that the mouse somehow shorted the MOBO? The laptop tries to get the drivers but it fails and then nothing. Should I order a new mouse too at this point?

Edit 2: Is it possible the hard reset fried it? When I boot up too the CPU led goes red for about 1 second then the DRAM goes on. The PC runs, all the fans are running, just no image to either of my monitors, can't get into bios or anything. Do you think my CPU could be damaged with the CPU light turning on red for a second? Pretty sure it's always done that though.
2 answers Last reply
More about asus p8p67 pro dram
  1. Tried plugging directly into the cord to bypass the surge protector, will try a new socket tonight when I get home. I'm not sure if maybe a short circuit could cause a loss in volts and maybe it's stopping the PC from fully booting?
  2. Bump?
Ask a new question

Read More

Motherboards