Sign-in / Sign-up
Your question
Solved

Razer Megalodon Headset not working!

Tags:
  • Peripherals
  • Gaming Headsets
Last response: in Computer Peripherals
June 27, 2014 12:29:19 PM

So i bought a new pc and was really excited to play the games i couldn't play in my old pc but the problem is the headset isn't working in the new pc,
What i tried :
-Disabling xHCI
-Installing firmware update
-reinstalling windows 7
-using usb hub
-reseting bios
-all usb ports i have
-used in my sister laptop and the headset worked fine

So what i noticed is when i plug it directly to the pc it doesn't recognize it, but if i use the hub it works but there is robotic sound and staticy and after few seconds there is no sound from the headset but it shows below ( in audio setting in the computer ) there is sound playing,

I really need help, i can't watch youtube videos without sound nor playing fps games without sound

More about : razer megalodon headset working

June 28, 2014 3:02:01 AM

Any one help me please?
m
0
l

Best solution

June 30, 2014 8:52:45 AM

Basically what I did (it's not a permanent fix, so I put an order for a new headset that works with win 8 and 8.1)
- Disable other audio devices in the Device manager
- Disable xHCI and legacy (if you have that one) in bios.
- Go to power settings in the control panel and disable usb setting.
- Go to device manager and click on all the usb devices and uncheck the box in the powermanagment tab.
- Do not connect any other usb devices.
- Restart
- Last thing is the tricky part, plug the megalodon into different usb ports and fiddle with uninstalling the (unknown usb device) that comes up in the device manager. Basically just try different ports while you sometimes uninstall the unknown usb device. With some luck it works.
- Plug in other usb devices if you have any (I just have a logitech wireless mouse)

When it works, for me at least, the mic doesnt work at all, but audio quality is just as good as ever. Some games I have to restart to get the audio to kick in, it does not always kick in when you start it up.

After alot of trying, failing and black magic its the only way I get it to work with win 8.1 on usb 3.0 ports.
Share