Solved

First Boot on Asus Z97 Pro - No USB in Windows

Just moved up to the z97 chipset with a 4790k. Win 7 x64 still installed on my ssd from previous build.


I booted to the BIOS, loaded defaults and set the board to xmp mode. Went to select primary boot device, and my ssd was not listed (got my SATA data HDD, Blu Ray drive, and "generic storage device". I went to the f8 boot list and was able to see my ssd there. On booting from that, I get to my login screen and my USB mouse and keyboard turn off their led lights and don't function.

I unplugged the other SATA devices and ensured my ssd is in the first port, now it boots directly to it (was getting a bootmgr error before until I manually selected in bios). However, I'm still having my USB Peripherals turn off at the windows login screen.

I've tried both my asmedia and Intel USB ports, both 2.0 and 3.0. Not sure what else to try.
16 answers Last reply Best Answer
More about boot asus z97 pro usb windows
  1. I've attempted unplugging power and holding down the Mobo power button for 10 seconds, a compatability check on memory, booting to safe mode (never given the option), and reinstalling Windows. I can't do the latter as I have no keyboard or mouse to progress past the first installation screen.
  2. I've now also tried a memok check, cleared cmos, successfully booted to safe mode (still couldn't get past login), attempted OS flashback (needed keyboard), attempted Windows repair (needed keyboard), and reinstalling OS (needed keyboard)
  3. Bios update via USB had no effect
  4. Any suggestions?
  5. Disabling the xHCI Controller in the USB Configuration section of my BIOS solved the problem, for anyone else with similar issues.
  6. Best answer
    Clean install?
  7. It was not, OS was installed from previous build. Wasn't able to reinstall due to the error I was getting.
  8. You run into a lot of issues when you try to switch boards without doing a clean install.
  9. SR-71 Blackbird said:
    You run into a lot of issues when you try to switch boards without doing a clean install.



    I attempted disconnecting the SSD and installing windows on another HDD, too. That didn't work either. I will keep that in mind in the future however.

    Would you suggest doing a clean install right before dismantling an old build (before installing any mobo software), or reformatting a drive before dismantling then installing it first thing on the new board? I've never wiped an SSD before, is why I ask. I have Secure Erase but have never used it. Not sure how reformatting would affect an SSD.
  10. It's good to start with a new or freshly formatted drive.
  11. Hello, I am just experiencing the same issue : Z97 MK2, 4770K, Windows installed. I can't use any keyboard or mouse while entering windows 7. In particular no way to load Z97 drivers.
    Darthmullet, have you found any solution that you could share ? Thanks
  12. I might have found a solution : go to BIOS, fast boot enabled, switch USB port to full support (not partially supported). It works for my Z97 MK2 sabertooth.
  13. Glad you got it figured out. As stated above, my problem was fixed by disabling the xHCI controller in BIOS.
  14. Hey Darthmullet -

    A year later, having the same problem, and found your answer. THANKS!
  15. Asus WS-97 here. Same issue. Disabling USB xHCI support in bios worked for me. I have seen this issue before when migrating Asus boards and trying to use the same hdd. Not sure if they are related.
  16. This is very old but the actual solution is in the USB settings page in the BIOS. It's the setting that says USB Legacy Support. Must be set Enabled.
Ask a new question

Read More

SSD Boot USB Motherboards Windows 7