Solved

MSI Z87-G45 problems with Samsung ssd on Windows 7 Installation?

I've had a system I built myself properly working for almost a year now. However, shortly after I updated the firmware on my Samsung ssd (840 pro series), I tried reinstalling Windows 7. I've installed Windows 7 on that same drive more than once before. However this time I received the following message: "Setup was unable to create a new system partition or locate an existing one." Apparently this message is a somewhat common problem. I can only think that's there's something going on between my motherboard and ssd after updating the firmware because I tried another ssd (also Samsung) just to be sure. The first ssd was an 840 pro series (128 GB) and the second was an 840 evo series (250 GB). I got the same message on both attempts. Also I bought the 840 evo series drive recently so it probably came with the upgraded firmware already.

I've tried cleaning the disk with diskpart and formatting the disk to ntfs with both command prompt (in the Windows installation) and gparted in linux. AHCI is enabled for my motherboard. I know my motherboard supports UEFI but every time I try to boot the windows 7 installation in UEFI it sends me back to the bios. I'm booting the Windows installation from a usb. Also, I have UEFI/Legacy mode enabled for my motherboard. There is no option to select only legacy mode.

Some suggested using a gpt partition table on other sites but I would like to avoid that since I know nothing about it. One last thing: I know both drives are fully functional because multiple linux distros install on them just fine.

My specs:

MSI Z87-G45 Gaming Motherboard
Samsung 840 Pro Series 128 GB ssd
Samsung 840 Evo Series 250 GB ssd
Corsair Vengeance 8 GB DDR3
Gigabyte Radeon HD 7970
Western Digital Blue 1 TB HDD x 2
Intel i5 4670K Haswell
6 answers Last reply Best Answer
More about msi z87 g45 problems samsung ssd windows installation
  1. So the only thing you changed was the SSD firmware but then all of a sudden both the drives developed issues?

    Which bios version are you on?
  2. Actually, I think it must be a motherboard issue for sure. I just tried installing Windows 7 to a regular hdd and I got the same error. I thought for sure it was an ssd issue because I had just updated the firmware. But I guess that could have been coincidence. I'm going to try updating the bios and see if that works.
  3. Okay so I can confirm that updating the bios did not work. Also I tried putting the Samsung pro ssd in my laptop and installing Windows 7. I got the same error. So I guess it must be an ssd problem after all.
  4. Best answer
    hmm interesting that your HDD and SSDs all have the same error but also in multiple dvices

    I wonder if your installer is corrupter or has some issue
  5. Yeah so I feel relieved, frustrated, and stupid all at the same time. It was the usb I was using to install. Switched to a different usb and it worked. That should have been my first guess because I've used the same usb for installs for a while and this time I was using a relatively new one. Anyway at least everything is working now.
  6. Nice that everything is working for you :)
Ask a new question

Read More

Samsung SSD Motherboards SSD Installation Error Windows 7 MSI-Microstar