Sign-in / Sign-up
Your question

Win7 + AMD 970 = HDD's lost after sleep

Tags:
  • Hard Drives
  • Windows 7
Last response: in Windows 7
July 12, 2014 6:35:57 PM

I've been running Win7 Pro since its release but now that I've upgraded to an FX-6300 (on a GA-970A) I lose all but the SSD (and USB3 thumb drives) every time the PC goes to sleep until I reboot, at which time they return. My config briefly is...

FX-6300 running as is from the factory
GA-970A-UD3P (and only one officially available for it, it's an AMI UEFI bios).
Radeon HD 7850 (on latest WHQL's); GSkill DDR3-2400 4gb x2 (at 2133@10-10-12 (1T); Antec 550W (3 rail, very reliable)

Now the drives: Toshiba SSD 128 gb (19nm MLC, my boot drive) and 3 Seagate HDD's: ST2000DM001 x 2TB, ST32000542AS x 2TB and an ST33000651AS x 3TB. I also use two USB drives and one BD-RE, a Toshiba 16gb, a PNY 8gb and a LiteOn iHBS112 (with PL06 firmware).

I have eight SATA 3 ports, 6 on the board and a PCIe card from Asmedia with two more; the 6 use an AMD controller and the card uses a generic controller which replaced the MS driver (but doesn't matter because either one makes no difference). I have tried using different controllers but the OS (or the motherboard) won't accept them, it's either these three (AMD, Asmedia or MS) in their places or nothing.

I've been searching all over Google and tried jumping the drives around the Sata ports and nothing works. So short of chucking $600 and replacing this with a $1000 Intel config (next time!) or just never running Sleep Mode again, did a solution ever appear for this ancient Win7 bug (which I understand exists in 8 and 8.1 also).

Thanks all for your time and I appreciate all sincere responses, even the humorous ones.

More about : win7 amd 970 hdd lost sleep

July 13, 2014 8:26:57 AM

tea urchin said:
erase the driver you suspect and let W7 install one of its own.(allow 7 to search for a driver from hardware manager).


Yep, that worked! (It restored the standard ACHI controllers) Thank you T-Urch, I should have seen that one.
m
0
l