Solved

280x overclocking problem

I've tried using afterburner and amd catalyst gpu overclocker but neither work, they both won't let me go past the stock clock speed of 1020mhz and 1500mhz for memory. On afterburner all the sliders are to the full right and i can only make it go to 1000mhz on clock speed and 1500mhz on memory speed. What gives? Why doesn't it let me go past stock clocks?
9 answers Last reply Best Answer
More about 280x overclocking problem
  1. Use only one overclocking settings.
    Did you click apply on MSI afterburner?
    Try reinstalling your gpu drivers
  2. https://imageshack.com/i/id57a49cp

    See, maybe the picture can help what im explaining.

    ive tried the newest afterburners and this one and all sorts that are supposed to work with this card and they all are like this.
  3. What is the brand of your 280X?
  4. Your msi afterburner should look like this for AMD cards:
  5. ya but how do i get it to look like that? Msi r9 280x

    I reinstalled my drivers multiple times and have tried many different versions of the drivers, same result
  6. Best answer
    Settings. Go to the tab "User Interface", choose default MSI afterburner skin.
    You may want to check the box "extend official overclocking limits" in the general tab
  7. When i try to reinstall my drivers it says, failiure to install package or something like that half way through.
  8. Clean uninstall and try again.
  9. it worked
Ask a new question

Read More

Go Overclocking Speed