New power supply no POST/no DISPLAY

CPU: Pentium Dual Core 1.6ghz
RAM: Kingston DDR2 667 2gb
GPU: Radeon HD4670
MOBO: ECS P4M-900T-m2 rev 1.0

I recently purchased a new PSU because my computer unexpectedly shut down the other day. I thought that my mobo was the problem because there is no light on the power button when i tried to switch it on when it shut down. But then, yesterday my friend came to check what happened and tried to replace my old PSU and it powers on (cpu and gpu fan spinning, LED light is on) but no POST/DISPLAY. I bought another PSU to check if my friends PSU is defective, but still same results, no POST/DISPLAY. What could be the problem?

- I already tried switching RAM Slots and putting one module at a time.(there's no beep indicating incorrect module)
- Removed the GPU and plugged VGA to the onboard(still no POST/Display)
- removed the CMOS to reset the bios (same results)

Hoping to find a solution from you guys. Thanks in advance.
1 answer Last reply
More about power supply post display
  1. well then i think your motherboard has died...i hope its a pretty old motherboard..
Ask a new question

Read More

Power Supplies Systems Displays