Sign-in / Sign-up
Your question
Solved

Cannot Install Windows 7 on Samsung 840 EVO; 0x8007045D error code

Tags:
  • Storage
Last response: in Storage
July 16, 2014 12:56:02 AM

Hello,
I was wondering if there was anyone who could help me at all with my situation. I have absolutely no idea what else to do here. Recently I purchased a 500GB Samsung EVO and from reading countless forums and reviews, it seemed that it wouldn't be that difficult.
I have tried several ways to get Windows 7 to install but was unsuccessful. First, I unplugged all other Hard Drives and left the SSD and DVD-ROM connected, inserted the OS DVD, set DVD-ROM to first boot, re-booted and let it do it's own thing. A few seconds into the "windows is unpacking/setting up", bootmgr screen comes up and says error with "Input/Output, please check that there are no other external devices connected and restart." I restarted and selected to boot from DVD-ROM first. The Windows Files unpacked, it gets to the setup screen, select the partition, I click install and when it gets to the "Expanding Files" it gives me this error "Windows cannot install required files; error code 0x8007045D."

I know there aren't any other devices connected, so I tried switching SATA3 cables and even bought new ones, switched the SSD to different ports and I still get nothing. The Windows CD I am using is the exact same one I used to install on my Seagate HDD's. But just to make sure, I created another bootable DVD using Windows 7 USB/DVD Burning Tool. I also created a bootable flash drive using the same software (win7 burning tool). I tried installing through UEFI in GPT format and still get the same error. I tried switching back and forth from IDE to AHCI and still get nothing. I thought that maybe since every time I tried installing the OS it would create the required partitions on the SSD (2 separate using MBR, and 3 partitions using GPT), I would delete them. So to rule that out (not installing on an unallocated partition) I would plug my HDD back in, boot from it, open Partition Magic or EaseUS, delete the partitions so that it would say "unallocated space", turn off the computer, disconnect the HDD, turn the computer back on and repeat those steps every single time I changed something. That still didn't work either.

I've tried taking out one memory stick, resetting CMOS, running memOK!, setting BIOS to default settings so that overclocking and all that can be ruled out too, and still get nothing. I tried having the HDD as a primary boot drive, in SATA Port 0 (or 1 depending on how you look at it) with win7 OS on it and the SSD as secondary so that even if the bootmgr files get scattered on different drives or partitions, at least I will be able to get an OS installed on the SSD. But that didn't work either. I have tried everything I could think of for the last 14 hours straight. I have read so many forums that I end up coming across the same ones again. I have absolutely no idea what else I can do now, PLEASE HELP!

My setup, just in case it might help with anything:

AMD A8-3870k 3.3ghz
Asus F1A75-M
G.Skill Sniper 1866, 2x4gb
Antec Earthwatts 380W
Seagate 2TB HDD
Seagate 1TB HDD
Corsair H60
...and that damn 500gb Samsung EVO..

More about : install windows samsung 840 evo 0x8007045d error code

Related resources
a b G Storage
July 17, 2014 10:58:08 AM

try another windows 7 install disk or usb.
m
0
l
July 18, 2014 7:55:39 PM

qazzi said:
try another windows 7 install disk or usb.


I have already tried using another Windows 7 disk, and USB. I mentioned in the first post all of the things I tried, which did not work.
m
0
l
July 18, 2014 9:56:08 PM

Just a quick update. I tried using the same Windows 7 DVD, from when I did the very first install on my HDD a while back, on a different HDD and it works just fine. I also got a different Windows 7 OS, onto a DVD and USB, issued by my college. That one works perfectly on the HDD as well. I still cannot get it to install on the SSD and have tried countless different things, none of which have worked for me so far. What about a Secure Erase on the SSD? Will that at least help determine if something is wrong with the SSD itself? If I do that, would I no longer be able to return or exchange the SSD with another one, should I choose to do so?
m
0
l

Best solution

a b G Storage
July 19, 2014 2:23:13 AM

just update to the newest bios, just want to ask is your SSD firmware updated too?
Share
December 14, 2014 12:54:41 PM

+1 to burning a dvd of the flash drive. USB 3.0 flash drives and this scenario don't work.

Burnt a bootable dvd and all installed.
m
0
l
January 25, 2015 4:02:28 PM

After 2 days of research (and reading this thread), here's what worked for me (with a Lenovo V570):

I had to get into the BIOS and change the SATA setting off "AHCI" to the other option, which I think was "Compatible" or something like that. Once I did that, and changed the type of drive to GPT using the directions from elsewhere in the forums, it suddenly started working. After I got Win7 installed, just for fun (?) I went back and changed it back to AHCI and it wouldn't work anymore, so I changed it back again. Weird wild stuff.
m
0
l