Solved

AC4BFSP.exe has stopped working

I've had the retail version of Assassin's Creed 4: Black Flag for about eight months now, and the game hasn't given me ANY problems to date when lately, it stopped working all of a sudden. Now, when I try to launch the game, through uplay OR by shortcut, it just doesn't seem to start. I just get the hourglass cursor and then get the message saying "AC4BFSP.exe" has stopped working. I have no idea what is causing this problem and I want to run the game once for screenshots to upload on my blog. Any help would be appreciated.
2 answers Last reply Best Answer
More about ac4bfsp exe stopped working
  1. Best answer
    Did you update the game or any drivers recently to have caused the problem? Re-installing the game may fix this.
  2. anonymous1 said:
    Have you tried to reinstall or uninstall the game?


    just about everyone has tried this, and despite reinstalling the game (for many, redownloading all 25+GB of it) the game continues to crash on startup.

    I played this game through for about 2 1/2 months, beat it, then decided to play again for prestige after about 1 year after I last played it. No dice. Tried every suggestion from Ubisoft, other gamers, etc. Nothing works. tried both with current patches and with fresh install no patching. Same result.
Ask a new question

Read More

Cursor Games