Solved

How to format a lexar 16gb usb flash drive when it is not showing in disk management?

My Lexar 16gb usb flash drive is showing very strange activities. Sometimes it is showing in the drive list and when I click the properties it shows- used space: 0 bytes, 0 bytes and Free space : 0 bytes 0 bytes. But in the general device status it shows-the device is working properly. When I go to volume it shows-Type:Unknown, Status:Unreadable, Partition style: Not Applicable, Capacity:0 MB, Unallocated space: 0MB, Reserved space: 0 MB. It is not showing in the disk management system. Once I proceed to format it but it tells me you have no sufficient authority to do this. I have updated the drivers, it says driver is up to date and changed the drive letter several times but no result. Sometimes the windows can not recognize it. I do not know what's the problem is. Do you have any suggestions?
3 answers Last reply Best Answer
More about format lexar 16gb usb flash drive showing disk management
  1. have you tried Diskpart? If you can find it, start with CLEAN before formatting.

    Also see if Lexar has a utility available.

    it really sounds to me like the drive has died.
  2. Thanks. I have tried Diskpart. When I select my desired part is shows "No media". So, I can not clean or partition it. I also tried list volume but it is not there. But I am not sure if the drive is dead. When I insert it to the usb port I am hearing a beep sound. It sounds again when I remove this. So, I think the drive is still alive. Anyway, I am checking with Lexar if I find anything.
  3. Best answer
    Flash drives are pretty cheap, I'd replace the thing if it causes issues. Something is clearly wrong with it, and to get it fixed will almost certainly cost more than just replacing it.

    Did you try this in another computer? If it does the same thing, toss it.
Ask a new question

Read More

Disk Management USB Flash Lexar Format