Sign in with
Sign up | Sign in
Your question

asus r9 280x - artifacting help please - drivers?

Tags:
  • Asus
  • Bug
  • Corsair
Last response: in Graphics & Displays
Share
July 17, 2014 7:37:01 PM

I just got this card its been about a week now. And im getting stupid Artifacts and other Spikes Graphic glitches in many different Games.... Arma 3 and sniper elite 3 , have been artifacting the most.

- I dont know how to fix this ,, maybe it's a bad card , but is their a way to fix this for sure?

I heard it could be the memory , im using corsair vengeance 1866 in the correct slot the motherboard told me to put them on 1.<<<empty>>> 2. [[RAM]]] 3.<<<Empty>>>. 4.[[[Ram]]]

SPECS: MSI z97 Gaming 5 motherboard. Asus R9 280x. Corsair Vengeance 8GB 1866.
Corsair cx750m , I5-4690k. H100i Cooler. Lots of Fans. SSD Samsung 250gb. and 250 HDD.

Heres some pictures of the spikes in arma 3.....








GPU INFO INSIDE GPU TWEAK FROM ASUS





AND MSI LIVE UPDATE 6 INFO.. I DONT KNOW WHY but my drivers are not updating correctly, Ive ran this program and it wont update bios it seems and some other things, im not sure why..

heres a picture below of the drivers...





More about : asus 280x artifacting drivers

July 18, 2014 6:30:22 AM

it could be your VRAM (graphics card ram) use GPU-Z and see the temps of the VRAM try running your GPU with 100% fans on and see if it still does it
m
1
l
a b Ĉ ASUS
July 18, 2014 7:33:40 AM

If it is artifacting out of the box, you are entitled to go back to the store you bought it from and ask for a replacement.
Its normals for GPUZ to report your card as R9 200 series. it has always been like that. Don't trust the BIOS reading from GPUZ, read the label on your gpu or the box that came with it unless you specifically flashing a different BIOS version to it.
It is most likely that the VDDC is running at 1.6v which is unstable for your card.

Manually download and update your drivers for your motherboard drivers website.
m
1
l
Related resources
July 18, 2014 10:07:53 PM

thanks for the replys, im probably going to rma this crap shit , everyone seems to be having problems and it hasnt gone away still...
heres a pic from gpuz



here is second pic after about 5 mins

m
0
l
July 19, 2014 12:49:20 AM

well try playing a game with the fan at 100% and GPU Z in the background and take a pic after a few min.
m
0
l
July 26, 2014 12:49:20 PM

I just RMA'd this piece of crap card instead
m
0
l
July 26, 2014 11:58:39 PM

First of all you need to TOTALLY remove all the old drivers. Use this link.
http://www.wagnardmobile.com/DDU/
Note:
Select the respective company(i.e Nvidia or ATI) drivers to be uninstalled.
Use clean and restart option.
And then install the new drivers after rebooting.
m
0
l
!