ASUS MAXIMUS VI FORMULA Bios stuck in I-ROG 2 is updating ... need help !!!

hello every one i was playing games on my asus maximus formula vi when a window came up and said a new update for bios is available do you want to download i thought why not so i downloaded it but i did not install and then it completed downloading and after a while the power went off for 3 hours and when it came back i powered up the pc and it says after the asus logo shows : I-ROG 2 IS UPDATING DO NOT SHUT DOWN OR RESET THE COMPUTER . and after it complete from 1% to 100% after 2 hours it reboots and do it all over again i have no idea why i tried every thing clear CMOS i tried flash drive the first release of bios and the same thing happens i even tried the dvd that came with my mother board and nothing i really need help thank you


NOTE: i cant get access to the bios it just there like a picture when i power the pc

pc spec: asus maximus formula vi intel i7 4770k Ram: corsair dominator 1866MHz 24gb Gigabyte GTX 770 4gb Corsair rx1000 watt ssd corsir 256 gb and three hdds each 1.5 tb wich gives in total 4.5 tb
13 answers Last reply
More about asus maximus formula bios stuck rog updating
  1. BIOS is need to be reflashed using programmer.
    If you have warranty = RMA
  2. i did reflashed the bios and now it shows 00 in qcode and nothing in display
  3. What kind of programmer did you used?
    What kind of file did you flashed?
  4. i used minipro programer and the latest file version 1505 it did not work and after i did flash bios usb it went back to the same problem i-rog 2 is updating .... so i think the problem is not in the bios chip
  5. Looks like its time to RMA.
  6. i cant RMA it because i live in morocco and i brought it from Ukraine no asus support in morocco and for me to get to ukraine the price ticket is 5 motherboards so im stuck!!!
  7. Tell me more about bios file: is it was CAP or ROM extension?
  8. its a CAP file and i have tried every version of them from the first release to the latest one
  9. There is a chance still.
    CAP will not help, you need ROM for programmer.
    I can get it.
  10. Read private message.
  11. okey i got it but i have to wait for the technician to open he got the programmer i will give him the bios chip and the file and we will see
  12. Well, looks like I can help to solve this problem :)
  13. Solved.
    Replaced both ROG chips.
    At front side:

    And at back side:
Ask a new question

Read More

Asus Formula BIOS