Sign in with
Sign up | Sign in
Your question

Catalyst Control Center problem spiraled to bigger issues

Tags:
  • Control Center
  • USB
  • AMD
  • Catalyst
Last response: in Windows 8
Share
July 20, 2014 12:44:19 PM

So....

I went to reinstall my Catalyst Control Center (ver. 14.4) to enable the software to work again. My CCC wouldn't open at all. I heard I needed to uninstall my AMD driver and the CCC. I did an Express uninstall instead of a Custom uninstall.

I lost my USB Drivers, thus my keyboard and mouse no longer function at the login screen. The Uninstall got rid of some AMD Usb Filter Driver, but they will work in the BIOS and in the Advanced Start-Up menu.

I tried System Restore twice--two different restore points...both times it failed. I also tried booting into Safe Mode--keyboard and mouse did not respond in Safe Mode either (go figure). I tried plugging the keyboard and mouse into different ports and into 3.0 ports...that did not work. And to top it off, I have no PS/2 ports.

I'm running out of patience, and I'm just thinking and just time Reset my PC for the THIRD time now. Goodbye 600Gb+ of data (games).

The computer boots up normally, but when I click or hit a key to remove the lock screen so I could type in my password, nothing happens.

Any help will be appreciated.

Computer specs:
HP Pavilion P6-2327c
Windows 8.1 64-Bit
8GB RAM 1600Mhz
AMD A8-5500 Quad Core @ 3.2Ghz, Turbo 3.7Ghz
Western Digital Blue 1TB 7200rpm
MSI MS-7778 Jasmine (ver. 1.0) Motherboard
AMD Radeon HD 7750 1GB GDDR5

More about : catalyst control center problem spiraled bigger issues

a c 290 À AMD
July 22, 2014 8:42:19 PM

Not sure what it is, but had troubles with 14.4 also, when uninstalled it doesn't clean up itself very well, I ended up disabling all from startup (using WinPatrol) then went to a restore from a couple weeks back
m
0
l
a b À AMD
July 22, 2014 9:55:18 PM

I am, of course, not saying this IS the case, and forgive me if you've already checked this but it's always good to start with the basics. The first thing I'd do is go into the BIOS and make sure that legacy USB is enabled. Otherwise, in some cases there can be stupidity issues with windows. Not always and not in every case but I'd just make sure it's enabled as a starting point. Just out of curiosity, how were you able to initiate a reset with no mouse or keyboard. No, don't hit me, I'm just wondering if I missed something.
m
0
l
Related resources
a c 290 À AMD
July 22, 2014 10:17:18 PM

Reset button, or turn off the PSU, unplug......I just got the 290X Matrix and it's a great card (as was the CU model of the 280X I got when it was released, but just get's old with AMD releasing buggy drivers, the 14.4 wouldn't pick up the second monitor on any of the rigs I tried (same with a 7870 in them yet the 13 series work OK (the 14.7 Beta was even worse, after it 'uninstalled' and I reload the 13 series, it picked up the second monitor but only would display in grey scales 9which is why I went to restore, had already spent a couple of day w/ the new drivers (contacted AMD twice (and of course no responses)....
m
0
l
a b À AMD
July 23, 2014 2:42:22 AM

Well, actually I was replying to the OP, and I was referring to the reset of windows he did that caused him to lose all his data. Resetting the power wouldn't be likely to cause that, except in extreme circumstances. Sorry about the misunderstanding.
m
0
l
a c 290 À AMD
July 23, 2014 8:37:21 AM

Was just pointing out ways to reset, but agree with him on the weird things CCC does that have nothing to do with drivers
m
0
l
July 23, 2014 9:32:10 PM

Thank you all for the replies. I had to reset my PC back to factory settings. All is up and running again. Got Windows 8.1 installed again, and I installed AMD Driver 14.4--and no problems so far.

I will NEVER do an Express Uninstall again.
m
0
l
a c 290 À AMD
July 23, 2014 9:37:33 PM

Glad to hear all is well ;) 
m
0
l
!