Problems with ccc drivers and amd apu

So i recently built a computer for my mother and put it all together and took all windows updates etc i have tried installing ccc before updates too i have reinstalled windows 3 times and everything.

Everythime i install catalyst drivers and it want to restart i get the drivers have stopped responding and the screen goes black every 2 second and its like freezed cant do anything only like move the mouse every 1 second after it has restored.

And it just keeps restoring the drivers until bsod.

So what could the problem be? the computer runs fine and all have for like 1-2 months now but i has no catalyst installed wich means it cant use the full potential of the integraded gpu right?

and no matter if i use the newest, beta or older catalyst drivers it just wont work, i have tried installed everything thats on the cd or to download everythigng from the offical sites still no change everything works except cant install catalyst i have done driver sweep.

And every time i install it and it starts to reset the drivers i have to boot into safe mode and do driver sweep to be able to log windows normaly at all,

Specs:
Kingstone fury 8gb 2x4gb 1866mhz ram
silverstone 500w psu
120gb kingstone v300 ssd
Gigabyte fm2 a88x or something mobo does not remember exact model
Amd a10-6800k black cpu
3 answers Last reply
More about problems ccc drivers amd apu
  1. Have you updated your windows yet.
    Download CPU Z and look up what motherboard you have.
  2. Suztera said:
    Have you updated your windows yet.
    Download CPU Z and look up what motherboard you have.


    I said i have taken the updates, and i said for my mother cant check with cpuz as i dont have the comp at home would need to go over there and i know the exact model if i check the box should still have it i just dont remember it without checking.

    Anyways i have latest bios and all that and have tried other have taken latest chipset etc or just the ones on cd still when ccc is installed it fucks up
  3. If you open up device manager, goto Display adapter and right click on the apu. Choose update driver software and select browse files and choose the AMD catalyst 14.4.

    See if this method works.
Ask a new question

Read More

Drivers Computers AMD CPUs