Sign-in / Sign-up
Your question

Black Screen and Cursor After Installing Graphics Card Drivers

Tags:
  • Cursor
  • Drivers
  • Graphics Cards
  • Graphics
Last response: in Graphics Cards
August 11, 2014 2:53:27 PM

I've got my new computer yesterday, custom built from the store, and I installed Windows 7 Ultimate, ran alright, everything was working. But then I installed the Graphics Card drivers, and since then I'm getting a black screen with a functioning cursor whenever I turn it on. It works fine on Safe Mode, but not on normal mode. I also tried installing Linux and seeing if it works. When I did it with Linux, it boots and goes to the desktop but I can't do anything, everything is frozen. It's a brand new computer from the store.
Specs:
Mother Board Z97-Gaming
Graphics Card Nvidia GeForce GTX760 2GB EVGA
Processor Intel Core i7 4790k
8 GB RAM
Anybody got any clues?

More about : black screen cursor installing graphics card drivers

a b U Graphics card
August 11, 2014 3:05:03 PM

Why would you install graphics drivers? The PC should have come ready to go out of the box. What drivers did you install, from the NVIDIA website? You made need to use your warranty and take the PC back to the store.
m
0
l
August 12, 2014 2:24:22 AM

avenseth12 said:
Why would you install graphics drivers? The PC should have come ready to go out of the box. What drivers did you install, from the NVIDIA website? You made need to use your warranty and take the PC back to the store.



Sir, It's a custom build PC not package. here in our country pc stores will let you pick/customize your own PCs upon buying. they will only boot you to bios not to system (as all the HWs were fresh from the box) to let you see if the HWs are working properly.so basically, formatting, driver/software installation is up to you @home

But.. i dunno if we're in the same country tho :) 
m
0
l
August 12, 2014 2:33:58 AM

Jashani said:
I've got my new computer yesterday, custom built from the store, and I installed Windows 7 Ultimate, ran alright, everything was working. But then I installed the Graphics Card drivers, and since then I'm getting a black screen with a functioning cursor whenever I turn it on. It works fine on Safe Mode, but not on normal mode. I also tried installing Linux and seeing if it works. When I did it with Linux, it boots and goes to the desktop but I can't do anything, everything is frozen. It's a brand new computer from the store.
Specs:
Mother Board Z97-Gaming
Graphics Card Nvidia GeForce GTX760 2GB EVGA
Processor Intel Core i7 4790k
8 GB RAM
Anybody got any clues?


Hello! Return the whole unit to the store, there is a high possibilty of a MOBO's chipset problem, some MOBO manufacturers are going store to store to update all their h81- 97 chipset intended for haswell, i just bout a 4590 a month ago, I was suppose to purchase Asrock however the chipsets needs to be updated (the storeseller says) so i was forced to buy Asus tho it is a better brand since it's the only Mobo that time w/c was updated.

tho the problem persist upon installing V.card Driver but a Problem from an outdated MOBO is a possible problem either.

Ask the store if the MOBO needs to be updated. thanks
m
0
l
Related resources