Sign-in / Sign-up
Your question

ASUS M5A97 R2.0 + RAID + Samsung 840 Evo SSD = "Magician cannot communicate with the below Samsung SSD"

Tags:
  • Samsung SSD
  • Samsung
  • Evo
  • Storage
  • NAS / RAID
  • Motherboards
  • Asus
  • SSD
Last response: in Storage
August 13, 2014 8:43:50 AM

Current motherboard has 6 x SATA 6Gb/s ports ( http://www.asus.com/Motherboards/M5A97_R20/specificatio... ). They are separated into two groups: 1-4 and 5-6.

1-4 are used by raid: i have 4 hdds as a raid array
5 is used by ssd

In a BIOS, i see a settings for those 2 groups (1-4 and 5-6):
When i'm selecting settings for 1-4, i see 3 options: ide, raid, ahci (currently set to "raid")
When i'm selecting settings for 5-6, i see only 2 options: ide and raid (currently set to "raid")

That seems to be not that major issue, but Samsung Magician says it cant communicate SSD. However, it seems to work fine: i had installed Windows 8 on ssd and it is fine so far.



Any ideas how to fix that?

More about : asus m5a97 raid samsung 840 evo ssd magician communicate samsung ssd

a c 85 G Storage
a b Ô Samsung
August 13, 2014 9:02:38 AM

Since your in RAID, the computer is assigning the SSD a RAID SATA driver. You have to try and download the AMD AHCI driver and install that.
m
0
l
August 13, 2014 9:17:21 AM

Actually, i have them. Seems they are build-in Windows, as i didnt install them manually.

m
0
l
Related resources
a c 85 G Storage
a b Ô Samsung
August 13, 2014 9:22:34 AM

Right click on the one that says AMD AHCI RAID controller and select Update Driver Software. Then select Browse my Computer for driver software. Then select Let me pick from a list. Then in that list select the Standard Driver which is Microsoft's driver and then reopen magician.
m
0
l
August 13, 2014 9:25:27 AM

Palorim12 said:
Then in that list select the Standard Driver which is Microsoft's driver and then reopen magician.


I have only the same one in a list:

m
0
l
August 13, 2014 9:26:52 AM

Or should i select something from here?

m
0
l
August 13, 2014 11:08:06 AM

Actually, i'm more afraid that BIOS is not allowing me to set SSD to AHCI mode.
m
0
l
a c 85 G Storage
a b Ô Samsung
August 13, 2014 11:49:25 AM

Vitalii said:
Actually, i'm more afraid that BIOS is not allowing me to set SSD to AHCI mode.


You can't if you have a Raid array setup
m
0
l
August 13, 2014 12:59:10 PM

Palorim12 said:

You can't if you have a Raid array setup


Does that mean i can't use RAID + SSD (ACHI) with M5A97 R2.0?
But RAID uses 1-4 controllers, and SSD is on 5. In BIOS there are even 2 different options for them.

m
0
l
August 15, 2014 4:34:34 AM

Guys? Should i buy a separate controller for SSD?
m
0
l
a c 85 G Storage
a b Ô Samsung
August 15, 2014 9:20:08 AM

You can only have 1 setting set in the BIOS and it has to be set before the Windows Installation.
m
0
l
February 3, 2015 8:11:03 PM

i cant even get raid of any kind to work on the same board
m
0
l
February 16, 2015 3:03:17 PM

Ferenzee said:
i cant even get raid of any kind to work on the same board


This board is very stubborn when working with raid. After many headaches I ended up with setting the 1-4 to raid and the ROM to legacy ROM and 5-6 as ide. Everything including the raid and my ssd that's on 5 is working "great" kinda bugs me I can't set my ssd to gpt instead of MBR but its the only way I could get everything to play nice with each other.
m
0
l