Sign in with
Sign up | Sign in
Your question
Solved

(Dual boot win7 & Linux Mint) MBR boot flag error, grub won't load. [FIXED]

Last response: in Linux/Free BSD
Share
August 15, 2014 10:58:45 AM

After convincing a family member to become a linux user, we decided to use his old netbook (Compaq mini CQ10-400CA) to create a dual-boot system, combining Linux Mint and Windows 7 Starter. After having tried Mint on a usb, we installed it onto the Windows recovery partition; the reason why I did this is because I built an SSD (Samsung 840 EVO 120GB) into his netbook and still have the original partitions on his HDD (I have no access to the HDD at this moment in time as it's at my relative's place far away).
Mint worked perfectly. After having used mint, I rebooted the netbook so that I could log in to Windows. However, when I tried to load Windows 7 Starter (from the GRUB menu), I got a "MBR not found" message. There were two listings for windows 7 in Grub, the other being a HP recovery boot partition (--> Deleted, so pretty much useless).
I used the Boot-repair-disk to restore the MBR (choosing the correct drive from the list), however when I turn on the computer I now get a MBR issue, (Windows Boot Manager; Windows failed to start... Status 0xc000000f The boot selection failed because a required device is inaccessible.
So then I decided, not being able to boot into any OS now, to use a live USB to recover it. Ubuntu, mint, boot-repair-disk; I tried these three but none of them worked. All I get is the "SYSLINUX 4.06 EDD 4.06-pre7 Copyright (C) 1994-2012 H. Peter Anvin et al" message, or the screen flashes once with the syslinux message for less than a second after which I get an empty prompt (no terminal, just an empty screen with a prompt in which I can't type anything).
So far I've used isotousb, Unetbootin, and Universal USB installer.
I have access to W8.1, OSX10.9 and various linux distros on my other systems and have access to all hardware equipment (with the exception of a HDD dock and a windows recovery disk {my windows 7 ultimate disk won't fix the mbr either}).
Basically, my boot flags are messed up and I can't correct it.
Thanks in advance.

I used a different USB stick and managed to get into Boot-repair-disk. If I make any progress, I will post it here.

I fixed the MBR. What the problem was is that HP created several partitions on their hard drive (OS, recovery, data and, most importantly, BOOT), and that I chose to fix the MBR on the OS partition, not on the boot partition. I will post back on how I got mint in the MBR/Grub to load as well as Win7 after I do it.

Best solution

August 15, 2014 12:08:47 PM

Using Boot-repair-disk, I fixed Grub. It is now possible to boot into both windows and Linux Mint.
Share
!