Solved

New build won't power up!

http://pcpartpicker.com/p/Ww2kHx

Here is my build, just pieced it together in PCPartPicker so you guys could see it. I powered it up and it brought me to the 'New CPU/Mobo' start up screen, so I turned it off and got it into place, plugged it all back up and now it won't work. Nothing was knocked/dropped, literally just shuffled to the side a little and the case put back on.

Opened it back up, no wires knocked out/dislodged - all is still solid. Any advice?
7 answers Last reply Best Answer
More about build power
  1. Well a 500w bronze PSU with all that seems kinda iffy, and you might really be pushing it. Do you have a higher wattage PSU to try it with, or a less powerful graphics card?
  2. Removed the GPU entirely and let it run off the integrated - still nothing.
  3. Best answer
    Actually, it could be your PSU. If its not even turning on this is my guess, you would get something even if the mobo was dead or something.
  4. I managed to get it working, one of the pin-sockets was not going in properly. Straightened it out and it's working.

    I know this PSU is a 38amp 12v and the GPU tops out at 42amp 12v. Will this cause too many issues? Should I upgrade the PSU soon anyway?
  5. Could someone give me something better that I could replace it with, or will this be safe? Preferably not too much more than $60.
  6. Should be fine is my guess.
  7. Anonymous said:
    Could someone give me something better that I could replace it with, or will this be safe? Preferably not too much more than $60.

    The cx should do without overclocking,for a better and cheaper one could you look at this one,
    http://pcpartpicker.com/part/rosewill-power-supply-hive550

    Looks like Anonymous has left the building.:p
Ask a new question

Read More

Power Up Systems New Build