Solved

USB 3.0 only works at USB 2.0 speeds

This is the motherboard: http://www.gigabyte.com/products/product-page.aspx?pid=4716#ov

I have the latest BIOS installed (I have aslo tried other versions) and also the AMD chipset driver (includes chipset \ sata RAID \ VGA \ USB driver).

OS is Windows 7 64 bit. I wanted to tried whether it works on Linux but I was not able to run a live Ubuntu 14.04 (that supports UEFI).

Whenever I connect USB 3.0 capable device (external HDD) to and USB 3.0 port, I get message saying "This device can run faster if you connect it to an USB 3.0 port". And I only get USB 2.0 speeds.

What is the problem?
9 answers Last reply Best Answer
More about usb works usb speeds
  1. It is often, bios settings, or drivers, but it looks like you have covered those. There have been many many problems with usb controllers throughout the development of usb. One would think that they would have ironed them out by now. I would try contacting gigabyte and see what they say.
  2. The one thing not mentioned - are you using a USB 3.0 cable?
  3. Yes.
  4. I would try another USB-3 device and if it doesn't connect at USB-3 speed, I would contact Gigabyte and see if you need to RMA the mobo.
  5. Of course I have tried other devices and other ports.

    I will contact Gigabyte.

    I do not know what RMA stands for, but I really don't want to return the board. It will take enormous amount of my nerves to to that (due to bastards in the computer store and the need to get everything out and then back in the case again, and maybe even reinstalling the OS and all that bollocks). If the MB is faulty, I will not bother to replace it, it is just not worth it...

    P.S. I bought these components like half a year ago. I thought that it was a software issue (Windows "working" as intended). And I have an extremely bad experience with returning faulty parts to this particular computer store.
  6. RMA = Return Materials Authorization. Gigabyte may have a suggestion for you to try before replacing the mobo.
  7. ronintexas said:
    RMA = Return Materials Authorization.


    There is no such thing in my country.

    I have contacted Gigabyte. They now also have link to this topic.
  8. Best answer
    Gigabyte have replied and the solution was:

    "uninstall USB controller under device manager and reboot the OS to let OS detect on the hardware again."

    It now works. So it was probably some bug in their driver.
  9. Strange....Microsoft drivers work better than their driver.
Ask a new question

Read More

USB3 Motherboards