New Build problem, Power to the motherboard but no power to the system, need help

I just got all my parts for a new build I have been planning. I got a PSU earlier for another project but didn't get one for the build. I would use the earlier PSU because project didnt pan out like I wanted. PSU is a Raidmax Cobra Power 700w. I know I've heard some hate about it but it was solid for the other project and I thought it would be cool for the build. I put everything together, plugged it in and got no boot up. Smell alot of ozone so, I figured something died. I tried everything, changing CMOS battery, checked jumpers, did the green and black wire trick but nothing worked. I figure the PSU died or something. The green LED buib on the board lit up so, I figure the board is still good far as I can tell. I RMAed the Raidmax and order a EVGA one today. I'm just wondering what went wrong and praying that my motherboard is still good. Anybody got any ideas?

Also my board is an ASUS M5A97 R2.0, RAM is G.Skill Sniper 8Gb, HDD is Seagate 1TB and WD 500gb (both SATA), Processor is AMD FX-6300.
1 answer Last reply
More about build problem power motherboard power system
  1. I'm guessing something in the PSU blew, i had a 630w Raidmax for a while and the noises and smells that would come out of it were scary. Hopefully it didn't take any of your other components with it.
Ask a new question

Read More

Components Power New Build