Solved

Avermedia Live Gamer HD (Device Not Found)

For some reason neither OBS, RECentral, or Device Manager is recognizing my Avermedia Live Gamer HD. I installed the card, installed the driver, then went to install the firmware but it wouldn't install it would just give me the error message device not found. I've uninstalled and reinstalled the driver, restarted my computer and everything. I went into my BIOS and it shows the device is there but it just reads "Unknown Device". I've tried all the different PCI Slots except the one my graphics card is cover. I'm just at a loss as to what I need to do to get this thing to work. I plugged my console and monitor into it and they both worked and display fine. Please help!


i5 4690k
MSI Z87-G45
16gb 1600mHz Corsair Vengeance (4x4)
Sapphire R9 270x Dual-X
120 PNY SSD Pro
1 TB WD Blue
LEPA 1000w 80+ Bronze
2 answers Last reply Best Answer
More about avermedia live gamer device found
  1. Hello, I'm experiencing the exact same problem, have you contacted any support about this?
  2. Best answer
    mtcaudill i've found out what you have to do, you'll have to find the correct driver for your avermedia, as i wrote above i had the same problem with my card. What i did was i uninstall windows fully on my computer to fix this, it seems that windows wont completely uninstall your drivers even when you click uninstall in Device manager. If you're using windows 8 or 8.1 it's really easy, you can just google the windows reset 8 / 8.1 and you'll reset it to factory settings. All you need to do now is that you need to download the driver again and you're good to go. Sure it's a bit pain in the ass to reinstall everything, but atleast you havent wasted 150+ euros on a card that dosen't do anything !
Ask a new question

Read More

Avermedia Devices Graphics