Cannot Update Past 14.1 AMD Drivers

I want to apologize if this isn't the proper place to post a question like this.

I have been trying to update my drivers for the past 5 hours. I am literally at a brick wall. I ran Display Driver Uninstaller (DDU) to make sure I cleaned any traces that can be causing an issue. I am not sure what else to do. I really hope to not do a fresh windows install, but if I have to, I will. Just trying to get other opinions before I get to that choice.

Here is a DDU Log. Hoping someone can tell me why this is the case. Sorry for the long text wall. I am just really ramming into a wall at this point

9/17/2014 7:19:35 PM >> DDU Version: 13.1.0.0
9/17/2014 7:19:35 PM >> OS: Windows 8.1
9/17/2014 7:19:35 PM >> Architecture: x64
9/17/2014 7:19:35 PM >> GPU #0000 Detected : AMD Radeon R9 200 Series
9/17/2014 7:19:35 PM >> GPU DeviceId : pci\ven_1002&dev_6810
9/17/2014 7:19:35 PM >> Vbios :113-C6310100-100
9/17/2014 7:19:35 PM >> Detected Driver(s) Version(s) : 14.100.0.0
9/17/2014 7:19:35 PM >> INF : oem10.inf
9/17/2014 7:19:35 PM >> INF Section : ati2mtag_R575
9/17/2014 7:19:35 PM >> --------------
9/17/2014 7:19:35 PM >> ddudr DP_ENUM RESULT BELOW
9/17/2014 7:19:35 PM >> The following third-party driver packages are installed on this computer:
oem0.inf
Provider: Microsoft
Class: Printers
oem1.inf
Provider: Realtek Semiconductor Corp.
Class: Sound, video and game controllers
oem10.inf
Provider: Advanced Micro Devices, Inc.
Class: Display adapters
oem100.inf
Provider: Razer Inc
Class: Human Interface Devices
oem101.inf
Provider: Razer Inc
Class: Human Interface Devices
oem103.inf
Provider: Razer Inc
Class: Human Interface Devices
oem104.inf
Provider: Razer Inc
Class: Human Interface Devices
oem105.inf
Provider: Razer Inc
Class: Human Interface Devices
oem106.inf
Provider: Razer Inc
Class: Human Interface Devices
oem107.inf
Provider: Razer Inc
Class: Human Interface Devices
oem11.inf
Provider: Microsoft
Class: Printers
oem12.inf
Provider: Advanced Micro Devices
Class: Sound, video and game controllers
oem13.inf
Provider: LG
Class: Monitors
oem14.inf
Provider: Xbox Peripherals
Class: Universal Serial Bus controllers
oem15.inf
Provider: Razer Inc
Class: Human Interface Devices
oem16.inf
Provider: Apple, Inc.
Class: Universal Serial Bus controllers
oem17.inf
Provider: Apple
Class: Network adapters
oem18.inf
Provider: SAMSUNG Electronics Co., Ltd.
Class: Universal Serial Bus controllers
oem19.inf
Provider: SAMSUNG Electronics Co., Ltd.
Class: Modems
oem2.inf
Provider: Realtek Semiconductor Corp.
Class: Sound, video and game controllers
oem20.inf
Provider: SAMSUNG Electronics Co., Ltd.
Class: Portable Devices
oem21.inf
Provider: Razer Inc
Class: Human Interface Devices
oem22.inf
Provider: Razer Inc
Class: Human Interface Devices
oem23.inf
Provider: Razer Inc
Class: Universal Serial Bus controllers
oem24.inf
Provider: Razer
Class: Human Interface Devices
oem25.inf
Provider: Razer Inc
Class: Universal Serial Bus controllers
oem26.inf
Provider: Razer Inc
Class: Human Interface Devices
oem27.inf
Provider: Razer
Class: Human Interface Devices
oem28.inf
Provider: Razer
Class: Human Interface Devices
oem29.inf
Provider: Razer Inc.
Class: Universal Serial Bus controllers
oem3.inf
Provider: Realtek
Class: Network adapters
oem30.inf
Provider: Razer Inc
Class: Keyboards
oem31.inf
Provider: Razer Inc
Class: Mice and other pointing devices
oem32.inf
Provider: Razer Inc
Class: Mice and other pointing devices
oem33.inf
Provider: Razer Inc.
Class: Mice and other pointing devices
oem34.inf
Provider: Razer Inc.
Class: Mice and other pointing devices
oem36.inf
Provider: Advanced Micro Devices, Inc.
Class: Display adapters
oem4.inf
Provider: AMD
Class: IDE ATA/ATAPI controllers
oem44.inf
Provider: Razer Inc
Class: Universal Serial Bus controllers
oem55.inf
Provider: Razer Inc.
Class: Mice and other pointing devices
oem56.inf
Provider: Razer Inc
Class: Human Interface Devices
oem57.inf
Provider: Razer Inc
Class: Human Interface Devices
oem58.inf
Provider: Razer Inc
Class: Human Interface Devices
oem6.inf
Provider: Razer Inc
Class: Human Interface Devices
oem60.inf
Provider: Razer Inc
Class: Human Interface Devices
oem61.inf
Provider: Razer Inc
Class: Human Interface Devices
oem62.inf
Provider: Razer Inc
Class: Human Interface Devices
oem63.inf
Provider: Razer Inc
Class: Human Interface Devices
oem64.inf
Provider: Razer Inc
Class: Human Interface Devices
oem66.inf
Provider: Razer Inc
Class: Human Interface Devices
oem67.inf
Provider: Razer Inc
Class: Human Interface Devices
oem68.inf
Provider: Razer Inc
Class: Human Interface Devices
oem69.inf
Provider: Razer Inc
Class: Human Interface Devices
oem7.inf
Provider: Razer Inc
Class: Human Interface Devices
oem70.inf
Provider: Razer Inc
Class: Human Interface Devices
oem71.inf
Provider: Razer Inc
Class: Human Interface Devices
oem72.inf
Provider: Razer Inc
Class: Human Interface Devices
oem73.inf
Provider: Razer Inc
Class: Human Interface Devices
oem74.inf
Provider: Razer Inc
Class: Human Interface Devices
oem75.inf
Provider: Razer Inc
Class: Human Interface Devices
oem76.inf
Provider: Razer Inc
Class: Human Interface Devices
oem77.inf
Provider: Razer Inc
Class: Human Interface Devices
oem78.inf
Provider: Razer Inc
Class: Human Interface Devices
oem8.inf
Provider: AMD
Class: System devices
oem81.inf
Provider: Razer Inc
Class: Human Interface Devices
oem82.inf
Provider: Razer Inc
Class: Human Interface Devices
oem83.inf
Provider: Razer Inc
Class: Human Interface Devices
oem84.inf
Provider: Razer Inc
Class: Human Interface Devices
oem86.inf
Provider: Razer Inc
Class: Human Interface Devices
oem87.inf
Provider: Razer Inc
Class: Human Interface Devices
oem88.inf
Provider: Razer Inc
Class: Human Interface Devices
oem89.inf
Provider: Razer Inc
Class: Human Interface Devices
oem9.inf
Provider: Razer Inc
Class: Human Interface Devices
oem90.inf
Provider: Razer Inc
Class: Human Interface Devices
oem91.inf
Provider: Razer Inc
Class: Human Interface Devices
oem92.inf
Provider: Razer Inc
Class: Human Interface Devices
oem93.inf
Provider: Razer Inc
Class: Human Interface Devices
oem94.inf
Provider: Razer Inc
Class: Human Interface Devices
oem95.inf
Provider: Razer Inc
Class: Human Interface Devices
oem96.inf
Provider: Razer Inc
Class: Human Interface Devices
oem97.inf
Provider: Razer Inc
Class: Human Interface Devices
oem98.inf
Provider: Razer Inc
Class: Human Interface Devices
oem99.inf
Provider: Razer Inc
Class: Human Interface Devices

9/17/2014 7:20:06 PM >> Uninstalling AMD driver ...
9/17/2014 7:20:06 PM >> Trying to remove the AMD HD Audio BUS
9/17/2014 7:20:06 PM >> Found an AMD audio controller bus !
9/17/2014 7:20:06 PM >> array result: amdkmafd
9/17/2014 7:20:06 PM >> PCI\VEN_1002&DEV_AAB0&SUBSYS_AAB0148C&REV_00\4&6BBFA2D&0&0110: Removed
1 device(s) were removed.

9/17/2014 7:20:06 PM >> AMD HD Audio Bus Removed !
9/17/2014 7:20:06 PM >> Found a remaining AMD audio controller bus ! Preventing the removal of its driverfiles.
9/17/2014 7:20:06 PM >> PCI\VEN_1002&DEV_6810&SUBSYS_2336148C&REV_00\4&6BBFA2D&0&0010: Removed
1 device(s) were removed.

9/17/2014 7:20:06 PM >> DDUDR Remove Display Driver: Complete.
9/17/2014 7:20:06 PM >> Executing Driver Store cleanUP(Find OEM)...
9/17/2014 7:20:06 PM >> oem10 Found
9/17/2014 7:20:06 PM >> -f dp_delete "oem10.inf"
9/17/2014 7:20:06 PM >> Executing Driver Store CleanUP(delete OEM)...
9/17/2014 7:20:07 PM >> Driver package 'oem10.inf' deleted.

9/17/2014 7:20:07 PM >> oem12 Found
9/17/2014 7:20:07 PM >> -f dp_delete "oem12.inf"
9/17/2014 7:20:07 PM >> Executing Driver Store CleanUP(delete OEM)...
9/17/2014 7:20:07 PM >> Driver package 'oem12.inf' deleted.

9/17/2014 7:20:07 PM >> oem36 Found
9/17/2014 7:20:07 PM >> -f dp_delete "oem36.inf"
9/17/2014 7:20:07 PM >> Executing Driver Store CleanUP(delete OEM)...
9/17/2014 7:20:07 PM >> Deleting the specified driver package from the machine failed

because it is not an third-party package.

9/17/2014 7:20:07 PM >> oem4 Found
9/17/2014 7:20:07 PM >> dp_delete "oem4.inf"
9/17/2014 7:20:08 PM >> Executing Driver Store CleanUP(delete OEM)...
9/17/2014 7:20:08 PM >> Deleting the specified driver package from the machine failed

because it is in use by a device.

9/17/2014 7:20:08 PM >> oem8 Found
9/17/2014 7:20:08 PM >> dp_delete "oem8.inf"
9/17/2014 7:20:08 PM >> Executing Driver Store CleanUP(delete OEM)...
9/17/2014 7:20:08 PM >> Deleting the specified driver package from the machine failed

because it is in use by a device.

9/17/2014 7:20:08 PM >> Driver Store CleanUP Complete.
9/17/2014 7:20:08 PM >> Executing DDUDR Remove Audio controler.
9/17/2014 7:20:08 PM >> HDAUDIO\FUNC_01&VEN_1002&DEV_AA01&SUBSYS_00AA0100&REV_1003\5&B17C04E&1&0001: Removed
1 device(s) were removed.

9/17/2014 7:20:08 PM >> DDUDR Remove Audio controler Complete.
9/17/2014 7:20:08 PM >> Executing Driver Store cleanUP(Find OEM)...
9/17/2014 7:20:08 PM >> oem36 Found
9/17/2014 7:20:09 PM >> -f dp_delete "oem36.inf"
9/17/2014 7:20:09 PM >> Executing Driver Store CleanUP(delete OEM)...
9/17/2014 7:20:09 PM >> Deleting the specified driver package from the machine failed

because it is not an third-party package.

9/17/2014 7:20:09 PM >> oem4 Found
9/17/2014 7:20:09 PM >> dp_delete "oem4.inf"
9/17/2014 7:20:09 PM >> Executing Driver Store CleanUP(delete OEM)...
9/17/2014 7:20:09 PM >> Deleting the specified driver package from the machine failed

because it is in use by a device.

9/17/2014 7:20:09 PM >> oem8 Found
9/17/2014 7:20:09 PM >> dp_delete "oem8.inf"
9/17/2014 7:20:09 PM >> Executing Driver Store CleanUP(delete OEM)...
9/17/2014 7:20:09 PM >> Deleting the specified driver package from the machine failed

because it is in use by a device.

9/17/2014 7:20:09 PM >> Driver Store CleanUP Complete.
9/17/2014 7:20:09 PM >> Removing AMD Audio Endpoints
9/17/2014 7:20:09 PM >> SWD\MMDEVAPI\{0.0.0.00000000}.{10E7366A-17DD-4259-B407-6ACCEFB5C1FD}: Removed
1 device(s) were removed.

9/17/2014 7:20:09 PM >> ddudr Remove Audio/HDMI Complete
9/17/2014 7:20:09 PM >> ddudr Remove Monitor started
9/17/2014 7:20:09 PM >> DISPLAY\GSM598E\1&8713BCA&0&UID0 : Removed
1 device(s) were removed.

9/17/2014 7:20:09 PM >> DISPLAY\GSM598E\5&35BE6B9A&4&UID0 : Removed
1 device(s) were removed.

9/17/2014 7:20:09 PM >> DISPLAY\GSM598E\5&35BE6B9A&4&UID265 : Removed
1 device(s) were removed.

9/17/2014 7:20:09 PM >> Cleaning Process/Services...
9/17/2014 7:20:10 PM >> Process/Services CleanUP Complete
9/17/2014 7:20:10 PM >> Control/Video CleanUP
9/17/2014 7:20:10 PM >> Cleaning known Regkeys
9/17/2014 7:20:10 PM >> Starting dcom/clsid/appid/typelib cleanup
9/17/2014 7:20:10 PM >> Begin classroot CleanUP
9/17/2014 7:20:10 PM >> End classroot CleanUP
9/17/2014 7:20:11 PM >> Start Interface CleanUP
9/17/2014 7:20:11 PM >> END Interface CleanUP
9/17/2014 7:20:11 PM >> Instance class cleanUP
9/17/2014 7:20:11 PM >> MediaFoundation cleanUP
9/17/2014 7:20:11 PM >> AppID and clsidleftover cleanUP
9/17/2014 7:20:11 PM >> Begin clsidleftover CleanUP
9/17/2014 7:20:12 PM >> End clsidleftover CleanUP
9/17/2014 7:20:12 PM >> Record CleanUP
9/17/2014 7:20:12 PM >> Assembly CleanUP
9/17/2014 7:20:12 PM >> ngenservice Clean
9/17/2014 7:20:12 PM >> Pnplockdownfiles region cleanUP
9/17/2014 7:20:12 PM >> System environement cleanUP
9/17/2014 7:20:12 PM >> Remove eventviewer stuff
9/17/2014 7:20:12 PM >> Removing known Packages
9/17/2014 7:20:13 PM >> -Starting S-1-5-xx region cleanUP
9/17/2014 7:20:18 PM >> -End of S-1-5-xx region cleanUP
9/17/2014 7:20:18 PM >> No value exists with that name. AMD AVT
9/17/2014 7:20:18 PM >> SharedDLLs CleanUP
9/17/2014 7:20:19 PM >> Killing Explorer.exe
9/17/2014 7:20:19 PM >> Cleaning Directory (Please Wait...)
9/17/2014 7:20:20 PM >> Executing Driver Store cleanUP(Find OEM)...
9/17/2014 7:20:20 PM >> oem36 Found
9/17/2014 7:20:20 PM >> -f dp_delete "oem36.inf"
9/17/2014 7:20:20 PM >> Executing Driver Store CleanUP(delete OEM)...
9/17/2014 7:20:20 PM >> Deleting the specified driver package from the machine failed

because it is not an third-party package.

9/17/2014 7:20:20 PM >> oem4 Found
9/17/2014 7:20:20 PM >> dp_delete "oem4.inf"
9/17/2014 7:20:20 PM >> Executing Driver Store CleanUP(delete OEM)...
9/17/2014 7:20:20 PM >> Deleting the specified driver package from the machine failed

because it is in use by a device.

9/17/2014 7:20:20 PM >> oem8 Found
9/17/2014 7:20:20 PM >> dp_delete "oem8.inf"
9/17/2014 7:20:20 PM >> Executing Driver Store CleanUP(delete OEM)...
9/17/2014 7:20:20 PM >> Deleting the specified driver package from the machine failed

because it is in use by a device.

9/17/2014 7:20:20 PM >> Driver Store CleanUP Complete.
9/17/2014 7:20:20 PM >> Restarting Computer
20 answers Last reply
More about update past amd drivers
  1. Does your motherboard have integrated graphics in addition to your card?
  2. darkbreeze said:
    Does your motherboard have integrated graphics in addition to your card?


    This is my MOBO: http://www.pc-specs.com/mobo/GigaByte/Gigabyte_GA-970A-DS3P/2372

    It seems like it does not.
  3. So what does DDU do? Uninstall and look for updates or something, then install them?

    Have you downloaded 14.4 of the drivers from the AMD site, then tried to install the drivers if this is the case?
  4. Paul NZ said:
    So what does DDU do? Uninstall and look for updates or something, then install them?

    Have you downloaded 14.4 of the drivers from the AMD site, then tried to install the drivers if this is the case?


    I have. Several times. The catalyst suite says they are updated to 14.4, but my device manager has them at 14.1. I have tried uninstalling them completely through AMD catalyst tool, and DDU (they are supposed to wipe all traces of the driver to make a fresh install possible).
  5. Yeah, it doesn't. You might try going into device manager and uninstalling the device by right clicking on it, selecting uninstall, make sure in the confirmation window you check the box next to uninstall driver and then run the DDU afterwards. Reboot and try to install the new drivers. I'd try installing the 14.7 drivers here:

    (Download them so you have them before performing the above steps. You'll have to scroll down the page for the stable beta drivers.)

    http://support.amd.com/en-us/download/desktop?os=Windows%208.1%20-%2064#amd-catalyst-packages
  6. darkbreeze said:
    Yeah, it doesn't. You might try going into device manager and uninstalling the device by right clicking on it, selecting uninstall, make sure in the confirmation window you check the box next to uninstall driver and then run the DDU afterwards. Reboot and try to install the new drivers. I'd try installing the 14.7 drivers here:

    (Download them so you have them before performing the above steps. You'll have to scroll down the page for the stable beta drivers.)

    http://support.amd.com/en-us/download/desktop?os=Windows%208.1%20-%2064#amd-catalyst-packages


    I have tried the above step you recommended, but not with the beta drivers. I will do that now for the 10th time today and see if it makes a differenc with the 14.7 drivers.
  7. darkbreeze said:
    Yeah, it doesn't. You might try going into device manager and uninstalling the device by right clicking on it, selecting uninstall, make sure in the confirmation window you check the box next to uninstall driver and then run the DDU afterwards. Reboot and try to install the new drivers. I'd try installing the 14.7 drivers here:

    (Download them so you have them before performing the above steps. You'll have to scroll down the page for the stable beta drivers.)

    http://support.amd.com/en-us/download/desktop?os=Windows%208.1%20-%2064#amd-catalyst-packages


    So I did it with the 14.7 drivers and the suite says it is up to date, but when I go to my system's information/Device manager, the version is 14.2. Up from 14.1, so I guess there is progress, but still, not 14.7 drivers according to my system's information/Device manager.
  8. What does it say in programs and features and CCC itself?
  9. Paul NZ said:
    What does it say in programs and features and CCC itself?


    Pardon my confusion, but how do I check the driver version through them?
  10. Here is a Link to the issue. CCC says its 14.7 while Device manager shows 14.2

    http://i.imgur.com/dwnvN9p.png
  11. 14.2 is the driver version from the 14.7 CCC. So, you should be good. Were you actually having performance or driver problems or just wanted to be on the updated driver version to be safe?
  12. darkbreeze said:
    14.2 is the driver version from the 14.4 and 14.7 CCC. So, you should be good. Were you actually having performance or driver problems or just wanted to be on the updated driver version to be safe?


    First off, I want to thank you Darkbreeze and Paul NZ for sticking around and trying to help.

    I have been having FPS issues for the past few days. games I used to play on High settings, I can barely maintain 15-30 FPS all of a sudden. I figured drivers were the issue since I noticed the driver numbers and conflicting information from the Imagur link I posted. So 14.2 is in fact the most updated driver available? Not 14.7? Sorry for my confusion.

    If that is not the issue, then I am at lost with my performance issues.
  13. Catalyst control center 14.4 reports Driver Packaging Version 14.10.1006-140417a-171098C.

    CCC 14.7 reports driver version 14.2
  14. So the package Number is in fact the correct version of the driver itself. I was so confused with the 14.7 and 14.2 numbers. Thank you for that clarification.

    So now I am in awe why I have performance issues then. Thank you for that information darkbreeze. SO i reinstalled and installed drivers for 4 hours for no reason :|
  15. Have you tried adjusting settings in individual games? If you have a specific game with problems try googling the game title and settings and see what you find. Almost certainly you won't have been the first person to experience the same problem with your hardware on any given title.
  16. What is the model number of your GPU?
  17. R9-270x
  18. In addition, the reason i thought it was my drivers was because I did this test: http://www.3dmark.com/3dm/4074274

    It was reccomended by a tech agent and the test results said Graphics Driver not approved. During the tests, The physics test was brutal for my GPU. It slowed down to 5-15 FPS every time. I was able to play games like Smite and BF4 on high settings with no issues whatsoever. I can barely maintain 15-20 fps now in them. Howver, Titanfall on high settings, it doesnt dip below 55 FPS. I dont get it.

    If you check the detailed results, the physics portion of the tests were brutal. On BF4, building falling apart never slowed me down. I tried it yesterday, and I almost froze on falling buildings. On smite, when minions go flying I drop to 20-30 FPS down from 150..i dont get it.
  19. It may show the version at the end of the entry for the drivers in programs and features
  20. Did you make any changes to settings prior to the issues starting? Go from high to ultra maybe? It could be the card itself. That's a decent card but it's certainly not a high end or top shelf card. It should certainly manage better than 15fps on high settings though. Perhaps something else is affecting performance. Have you installed any other programs or drivers between when it was working well and when it started screwing up?
Ask a new question

Read More

Drivers Problems AMD DDU Devices Issue CCC Catalyst