Solved

PLEASE HELP!!! games not working as well as they previously did after getting a new hard disk and windows

Okay so, a few days ago my WD 500 gb (blue) hard disk gave up on me, so I got a new WD hard disk (500 gb blue) and got genuine windows 7 professional x64 installed on it (previously had windows 7 professional aswell but I think it was pirated) Anyways so I installed the latest drivers for my GPU and stuff and downloaded and installed FIFA 15 from origin that I had previously purchased and was playing it on the previous OS and Hard Disk but the thing is that I'm not getting a stable 60 fps now (keeps dropping to 58-56-52) even though my GPU's core clock doesn't go beyond 1050 MHz while playing (its clocked at 1200 MHz) the temps are fine aswell and I used to get a constant 60 fps on my previous OS and HD. So, can anyone PLEASE tell me why this is happening?
(Note : I am playing on the same settings)

Specs - CPU -Intel Core i3-2120 @3.30 GHz
RAM - 8 gb (1333 MHz)
GPU - Sapphire R7 260x 2gb oc
OC - Windows 7 Ultimate x64
Mobo - Intel DH61WW
PSU - Cooler Master Thunder 450w
6 answers Last reply Best Answer
More about games working previously hard disk windows
  1. Hi -
    Your replacement may be the same "blue" WD HD, but there is a possibility that it has differences. You would have to check the specs like RPM, cache, and data transfer rate to see if they are exactly the same.

    Hope this helps.
    ###
  2. GorfTheFrog said:
    Hi -
    Your replacement may be the same "blue" WD HD, but there is a possibility that it has differences. You would have to check the specs like RPM, cache, and data transfer rate to see if they are exactly the same.

    Hope this helps.
    ###


    well they aren't exactly the same bc the one I bought now is like a newer version of the previous one I had
    but I wanna know why I'm getting unstable fps
  3. Hi -
    Newer yes, but maybe not the same performance specs?

    Based on your original description, I would posit that there is some bottleneck outside the GPU. At least, that would be consistent with your GPU not clocking at its max rate.

    Since the disk and the OS are the ony two things you've changed...

    Have you tried a graphics card benchmarking tool like Furmark to see what info you get from that?

    Also maybe try a disk benchmarking tool to see if the disk is performing up to specs.
  4. Did you install the same video drivers as before or is it a different version?
  5. smeezekitty said:
    Did you install the same video drivers as before or is it a different version?


    I've tried the same drivers as well as the latest and it didn't fix the issue
  6. Best answer
    Have you updated windows 7, including service packs and various other patches? I doubt HDD performance is effecting your game FPS. As once the game is loaded into RAM, your HDD is out of the picture, unless it is constantly refreshing content or loading custom animations or something of the sort.
Ask a new question

Read More

R7 260x Western Digital Hard Drives Fifa 15 Windows 7