Solved

Need experienced help, maybe faulty R9 280X, please

Hi guys, first of all excuse me if i make any mistake, english is not my native language.

I just upgrade my pc from a XFX 5850 to this brand new card, the problem is whenever I installed the gpu driver on Win 7 i would get a BSOD on startup saying something about ATIKMDAG.SYS. It would continue till I boot on Safe Mode and unistalled the driver.
I made a fresh Win 8.1 install on my HD and the problem persisted, now the BSOD is ocasional but the driver does not seem to work. On Device Manager i get this massage: Windows has stopped this device because it has reported problems. (Code 43), and one ERROR appears when i log in saying something about wrong drivers for my gpu, even thought i already tried several versions of the Catalyst.

Here is my Specs:
Phenom II X4 955
M4A785TD-V EVO
2X4 G.SKILL 1600MHZ
XFX DD R9 280X
SEASONIC 620W S2II

When i try my old gpu everything works fine, i'm trying to belive the problem is not the gpu but maybe the old mb, already made the BIOS update to the newest available...

Please help me, thanks in advance for any help.
1 answer Last reply Best Answer
More about experienced faulty 280x
  1. Best answer
    The R9 cards do seem to share unexplained issues.
    Read the negative(0 and 1 egg) newegg user feedback comments for your card.
    http://www.newegg.com/Product/Product.aspx?Item=N82E16814150678

    Consider returning the card.
Ask a new question

Read More

XFX Graphics Video Driver Motherboards GPUs