Solved

GPU doesn't give out signal, but integrated graphics works

Hi,
I recently put my PC in a new case and it works perfectly except for the fact that my GPU doesn't give out a signal to my monitors. I have a back up GPU and it doesn't work either, but my integrated graphics works which is what I am using now. All the power connectors are plugged in, the fans are spinning, the card is fully inserted and I have reseated both cards a couple times.
This is my fourth time doing a case mod/switch/build so I am not a noob at this.
Any help is appreciated
9 answers Last reply Best Answer
More about gpu give signal integrated graphics works
  1. Hi, Have you tested different slot (if available)?
  2. alexoiu said:
    Hi, Have you tested different slot (if available)?


    Yep. Fans still spin but no display, same as other slot
  3. Did it work before switching cases?
  4. alexoiu said:
    Did it work before switching cases?


    Well i didnt want to overcomplicate it at first but I initially wall mounted the PC and it worked fine for 3 months until it starting BSODing me every 10 mins. I remounted in the case and now this is happening
  5. Try connecting an internal speaker to the motherboard to check if board and CPU do work.
  6. alexoiu said:
    Try connecting an internal speaker to the motherboard to check if board and CPU do work.


    have already done so, but no beep codes
  7. If no beeps when starting the board with only CPU and CPU fan installed, then it's either a board or a CPU issue.
  8. Best answer
    alexoiu said:
    If no beeps when starting the board with only CPU and CPU fan installed, then it's either a board or a CPU issue.


    runs perfect now but thanks
    changed the gpu slot and it worked
  9. Great. Good you've solved it.
Ask a new question

Read More

GPUs Cases Graphics