Solved

Msi R9 280x 3gb help

Hello my monitor always has black lines and weird flicker squares when i am on google and weird shapes pure black line that come and go often, also when watching youtube videos sometimes the screen has fine multi colored rainbow lines across it just flickering and spazzing out and this is unbearable to watch.

The above is not daily some days my card is totally fine and awesome.
When gaming it screen tears which i fix by alt tabbing but the main problem is these super fast flashes that make my head go weird sort of like a quick flicker on the screen lately i feel like i just have to get of the computer due to dizziness caused from this.

I know the cards are overclock older 7970's and a lot are problematic but i was wondering if i can help any of my issues with upping my power limit settings in AMD overdrive to say 50% or lower?
MY PSU is a corsair 750w with a i5 2500k not overclocked. case is corsair and well ventilated.

Also maybe the card is too hot and should i manually set it to run at 50% speed or higher? the noise does not bother me.

Thanks for any answers or discussions.
8 answers Last reply Best Answer
More about msi 280x 3gb
  1. I have to ask.. How old is the card? Did these problem occur when you first had it? Lots of 280X cards were sold with bad VRAM. Mine did and there was no fix other than replacing it.
  2. I bought it new on ebay from someone selling like 150 of them about 1 half year ago, it did come with warranty and it was like £50 cheaper than the shop prices at the time it was all sealed clean and smelling good and new lol, so i was satisfied that it had not been used. it took about 1 week for the problems to start and i have been dealing with it until now it has become unbearable. Did you replace your card?
  3. Best answer
    RagedAPE said:
    I bought it new on ebay from someone selling like 150 of them about 1 half year ago, it did come with warranty and it was like £50 cheaper than the shop prices at the time it was all sealed clean and smelling good and new lol, so i was satisfied that it had not been used. it took about 1 week for the problems to start and i have been dealing with it until now it has become unbearable. Did you replace your card?


    Yes... I had too. My problems started on Day 2 with my card. Thinking it could have been the drivers or software-related problem I decided to wipe my drive clean and do a new install.. but during the install process I had the colored lines across my screen.. it was then I realized it was a hardware-related issue.

    I contacted Gigabyte and after nearly a week they just said to replace the cable. I didn't want to wait a week between responses.. so I just RMA'd it back to Newegg and received a replacement within a week. This second card has worked flawlessly.

    I think MSI cards come with 3 year warranties. You should look into that to see if they could help you. Did you register the card or create an account with MSI?
  4. Did not register or create an account. I actually looked into the RMA but i was so confused with the support page and how to actually contact them to find out if they will let me send it to them and where to send it too.
    Also my friend said ( not sure if it is true ) to RMA it will cost me £40 since i am in Uk and MSI is in Germany so when i send the card to them there is no garente at all they will send me a new one or even fix the problem.
    Too here you have a new and working card flawlessly makes me want to send mine back as to be able to sit and browse or play games without another flicker etc would be the best amazing.
  5. RagedAPE said:
    Did not register or create an account. I actually looked into the RMA but i was so confused with the support page and how to actually contact them to find out if they will let me send it to them and where to send it too.
    Also my friend said ( not sure if it is true ) to RMA it will cost me £40 since i am in Uk and MSI is in Germany so when i send the card to them there is no garente at all they will send me a new one or even fix the problem.
    Too here you have a new and working card flawlessly makes me want to send mine back as to be able to sit and browse or play games without another flicker etc would be the best amazing.


    I'm not too sure about the pricing you said. I once had to RMA an XFX card back to XFX and the only cost was the postage...I just used first class from the post office... about $7 USD, I think..
  6. Thanks for your answers you helped me make my mind up i will RMA the card 1 more thing if you have the time.

    I created an account on msi and on the part it says enter Product Serial Number, any idea where to find this lol.

    Thanks again and i will pick you as the solution as something i can do for you in return.
  7. That's easy... you either need to look at the side of the original box it came in (sticker)... OR... you would have to pull out your card and read it from there. Also take note of your other components like PSU.. they may require you to give them the make/model/wattage of that, too.

    If push comes to shove... there is another fix I've read about. Sometimes if you're having "minor" artifact programs... some people have said they fixed it by getting a second card using that as the primary one and moving the older one to secondary and SLI/Crossfiring it.
  8. ahhh, well this is the first imo beast of a card i have ever had and my plan was in the future when it starts to struggle with games to reach the ultra settings i would add another one since by then it would be cheaper and save on buying one of the newer more powerful one's, if they do not let me get a new one from rma then i will buy another one of these anyway and cross my fingers since they are dirt cheap for the sexy graphics they knock out.
    Ok i found the serial number here goes nothing !
    Thanks again SBM i love this site and people like you who take there time to help others.
Ask a new question

Read More

Graphics