850 evo taking forever to load windows 10

Hi guys,

I'm having some problems with my 850 evo (Not even a month old). Its taking quite some time to load up windows 10. I had to reinstall my windows 10 onto my PC due to windows boot manager problems and not its taking 2 mins on the windows 10 loading boot (with the loading circle). When I am actually logged into the OS it works completely fine. Anyone know why its taking forever?

I do also have a 120GB SSD and a WD 2TB 7200 HDD.

Thanks in advance!
4 answers Last reply
More about 850 evo taking forever load windows
  1. What are your h/w specs? M/b, proc, amount of RAM, PS, etc.
  2. sounds like your drives crapping out, i had similar issues when my old 2tb wd black drive had a ton of bad sectors, maybe check your boot priority make sure trim commands on, in the ssd, and run some disk defrag/chkdisk on the wd 2tb. First thing you want to try though is removing the sata from the 2tb hdd and see if your pc boots faster.
  3. netyoda said:
    What are your h/w specs? M/b, proc, amount of RAM, PS, etc.


    CPU: 4790k
    RAM: Kingston HyperX Fury Black 16GB 1833mhz
    Moba: Asrock z97 Extreme 6
    GPU: MSI 980 Ti
    PSU: Corsair CX600M
  4. fudgecakes99 said:
    sounds like your drives crapping out, i had similar issues when my old 2tb wd black drive had a ton of bad sectors, maybe check your boot priority make sure trim commands on, in the ssd, and run some disk defrag/chkdisk on the wd 2tb. First thing you want to try though is removing the sata from the 2tb hdd and see if your pc boots faster.


    Looks like it wasn't my HDD or my 850 evo ssd, I removed my extra 120GB ssd and its loading even faster than before this happened. Thank you very much!
Ask a new question

Read More

windows 10 Storage Evo