Solved

New Build- trying to figure out what is going on, wont power on...

MY BUILD:
Phantek’s Luxe Case-
Seasonic 1050 W PSU- Snow White-
Asus Sabertooth 990fx r 2.0-
AMD FX-8350 Black Edition Vishera 8-Core 4.0GHz-
Thermal Grease- Gelid GC- Extreme
Swiftech 240-X Cooler
HyperX Fury White Series 32GB (4 x 8GB)
ASUS Strix GeForce GTX 970- X 2
Western Digital WD VelociRaptor 1TB hard Drives- X 5
Noctua NF-A14 industrialPPC-2000rpm- X 7
--------------------------------------------------------------------------
Trying to figure out what is going on, process of elimination of what is wrong or what am I missing or doing wrong. I have built many systems and never had this problem before.

Brand new build, all brand new parts- (see spec above): I Installed everything, went to push the power on button and nothing no power/any power at all.

I rechecked and triple checked all the connections making sure everything was right and secure and still no power. While I have no power to turn the PC on I do in fact see a green light on the motherboard indicating power and I see white lights coming from the video cards.

From what I know and saw in the book; The green lite that is lighting up on the motherboard is from the onboard led sb_pwr (standby power) it is a reminder you should shut down the pc before removing any parts.

The video cards light LED light is white it says in the book you have the power cable completely plugged in and it is feeding the card power properly.

I believe that means the motherboard is getting the power from the PSU. Correct? If so then the motherboard is not the problem….

Then after about 3 hours and about the 30th time of no power the system finally came on!

Everything worked fans, cpu cooler, the lighting of the case and everything worked so I left the system on for a few minutes looking at the temps etc. everything looked good and I powered the system down so I could add a dvd drive to install the OS disk and driver disks etc. and when I went to power it back on and nothing again!

20 more times nothing and repeated checking all connections nothing.

At that point I tried some of the individual parts the PSU in another system under full load perfect. The PSU and 7 fans with fan controller and all 5 hard drives all worked fine perfect.

I am thinking it might be the power button and the led lighting on the case not sure but what do you think?

Out of 50 times trying to power it on only once after the 30 to 40th time did it actually come on and every time I do get the lights on, on the motherboard and the graphics cards. So again I am thinking maybe it is the tower itself.
7 answers Last reply Best Answer
More about build figure wont power
  1. Best answer
    Try removing the case front panel wires from the board an start the pc by shortly touching with a screwdriver the 2 pin on the board corresponding to the case power button. See if starting.
  2. Trying to understand how to touch it. Do you mean take the 2 wires from the power switch connecting to the motherboard and unplug and touch and/or leave it on the motherboard pull it back a bit and touch with the screwdriver? Also can I use a test light to see if power is going to it?
  3. When pressing the case power button, you're actually shorting the 2 pins on the motherboard where the switch gets connected. Just touch with a screwdriver or whatever metallic object the 2 pins on the motherboard.
  4. okay thanks very much, just never done that before ty
  5. No problem. Did it start?
  6. Well I just did that and it still did not work. :-/ Here is what I did to make sure I did in right below is how I did it.

    1- I left the PSU unplugged all night and then plugged it back in

    2- Then I took the wire off the motherboard and

    3- turned the power supply on and saw the green light on the motherboard and saw the white lights on the video cards

    4- took the screwdriver and place on the 2 pins on the header and nothing...
  7. Okay this makes no sense at all to me at least however... The screwdriver method did not work at all BUT - BUT - BUT- I put the switch back in and held it in place with my finger and pushed the power button and it started right up. So it must be the switch, like I said though I tried 3 times the screwdriver and it did not work.

    So I just did this 5 times! Each time as long as I moved the switch back and forth holding it in and pushing the power button it worked, powered right up.
Ask a new question

Read More

Light Power New Build