Cisco 1841 routing to Arris TG862 not working

skyhawk3355

Commendable
Apr 21, 2016
4
0
1,510
Hi all,
So I recently bought a Cisco 2960 switch and a 1841 router. I currently have 3 vlans working with dot1q and trunking to connect all of them, but I can't seem to get out of the network through the modem. Here's what I have running on my router so far:
Current configuration : 1356 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1-C1841
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
clock timezone EST -5
ip cef
!
!
no ip dhcp use vrf connected
!
ip dhcp pool Wired
network 192.168.20.0 255.255.255.0
default-router 192.168.20.1
dns-server 209.18.41.61
!
ip dhcp pool Lan_Party
network 192.168.30.0 255.255.255.0
default-router 192.168.30.1
dns-server 209.18.41.61
!
ip dhcp pool Wireless
network 192.168.40.0 255.255.255.0
default-router 192.168.40.1
dns-server 209.18.41.61
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.20
encapsulation dot1Q 20
ip address 192.168.20.1 255.255.255.0
no snmp trap link-status
!
interface FastEthernet0/0.30
encapsulation dot1Q 30
ip address 192.168.30.1 255.255.255.0
no snmp trap link-status
!
interface FastEthernet0/0.40
encapsulation dot1Q 40
ip address 192.168.40.1 255.255.255.0
no snmp trap link-status
!
interface FastEthernet0/1
ip address dhcp
duplex auto
speed auto
!
ip route 0.0.0.0 0.0.0.0 xxx.xxx.208.1
!
!
ip http server
no ip http secure-server
!
!
!
!
!
control-plane
!
!
!
line con 0
line aux 0
line vty 0 4
login
!
scheduler allocate 20000 1000
end

I'm a CCNA student right now but I've been having some serious issues and any help would be great!
Thanks
 
Solution
Not sure what you did here.

Leave the fa 0/0 with dhcp so it get a ip from your gateway router. Then put nat outside on that interface. You want nat inside on all the sub interfaces. The nat statements will nat to the interface with overload.

Ralston18

Titan
Moderator
Skyhawk,

Forum rules prohibit helping with homework. To be honest I am not sure if the above is homework or not.

In any case, can you walk through (comment) your script explaining what each section is doing?

There are a couple of "things" that I do not follow....

And let us know where you think the problem may be. Thanks.
 

skyhawk3355

Commendable
Apr 21, 2016
4
0
1,510


Ralston,
Sorry about the confusion. This isn't homework, but just a really overly complicated home network setup. At any rate i'm having trouble getting my 1841 to route out to the internet through the cable modem. Or at least i'm pretty sure that's what the problem is. I've tried gateway of last resort, ive tried putting the dns server addresses in the dhcp pools. I'm just not sure what i'm missing. fa0/0 is in trunking mode and fa0/1 is connected to the modem. hopefully that clarifies everything and hopefully there's an easy answer.
Thanks
 

Ralston18

Titan
Moderator
Do it this way:

Take me through each section of script and explain it to me. What it is doing and how that fits into the bigger picture.

From a student's standpoint I would ask why does

interface FastEthernet0/0
no ip address
duplex auto
speed auto

have no ip address and

interface FastEthernet0/1
ip address dhcp
duplex auto
speed auto

does not?

What does the xxx.xxx mean in the ip route? Are you just hiding an IP address for the sake of this forum (ok and recommended) or is there some placeholder meaning. Why are there two "0.0.0.0"'s.

Help me understand your work. Can you provide a diagram showing the network and trunking...?
 
Your configuration is correct but it really depends how you are connecting it to the internet.

If the fa0/1 interface is getting ip addresses directly from the ISP then you are missing the NAT configuration in the 1841

If the device on fa0/1 is a consumer router/modem then you will need special configuration on that device....and it may not be possible. This router will receive 3 different ip blocks from your 1841 so it must have static routes to send the data back. It also must support the ability to NAT these mulitple subnets. This is the feature that most do not have even if they have static routes. Now you might be able to cheat and use 192.168.0.0/16 but again it really depends consumer routers are really stupid.
 

skyhawk3355

Commendable
Apr 21, 2016
4
0
1,510


So the modem i got from TWC is a ARRIS TG862. http://imgur.com/S0CrRc6 attached is the lan settings page. I'm not sure if that helps but i'm running out of different tries. I've seen a lot of setups with NAT enabled and setup on the 1841. Should i still have to do that?
 
It is running as a router. I would see if you can make it run as a modem/bridge only and run the nat on the 1841.

The nat is pretty simple you just have to make sure you put nat inside on all the sub interfaces and make sure you have a access list that will match all the subnets.

I have done NAT so much on cisco stuff that I find it pretty easy but it is kinda complex to learn. It is tested on the ccna , very simple ones, so you will have to learn it anyway.

I suspect it will be less learning to figure the cisco our than to try to get the arris to do static routes and nat.

You can to start leave the arris as it is and just do the nat config on the cisco. You will be running double nat but at least you will know if it doesn't work it is a cisco config rather than trying to bridge the arris and do the nat. You can then change the arris to modem/bridge mode after you get the cisco working and you won't have to make any changes to the cisco.
 

skyhawk3355

Commendable
Apr 21, 2016
4
0
1,510
okay! so a quick update. I am now able to ping 8.8.8.8 from the router without a hitch. I'm now having trouble connecting from a pc on the vlan... Here's the current running config:
Router#show run
Building configuration...

Current configuration : 1711 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
ip cef
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.0.1
ip dhcp excluded-address 192.168.1.1
ip dhcp excluded-address 192.168.20.1
ip dhcp excluded-address 192.168.30.1
ip dhcp excluded-address 192.168.40.1
ip dhcp excluded-address 192.168.40.2
!
ip dhcp pool Wired
import all
network 192.168.20.0 255.255.255.0
dns-server 192.168.0.1
default-router 192.168.1.1
!
ip dhcp pool Lan_Party
network 192.168.30.0 255.255.255.0
default-router 192.168.1.1
dns-server 192.168.0.1
!
ip dhcp pool Wireless
network 192.168.40.0 255.255.255.0
default-router 192.168.1.1
dns-server 192.168.0.1
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet0/0.20
encapsulation dot1Q 20
ip address 192.168.20.1 255.255.255.0
no snmp trap link-status
!
interface FastEthernet0/0.30
encapsulation dot1Q 30
ip address 192.168.30.1 255.255.255.0
no snmp trap link-status
!
interface FastEthernet0/0.40
encapsulation dot1Q 40
ip address 192.168.40.1 255.255.255.0
no snmp trap link-status
!
interface FastEthernet0/1
ip address dhcp
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
ip route 0.0.0.0 0.0.0.0 104.230.208.1
!
!
ip http server
no ip http secure-server
ip nat inside source list 7 pool no-overload
!
!
!
!
!
control-plane
!
!
!
line con 0
line aux 0
line vty 0 4
login
!
scheduler allocate 20000 1000
end

Thanks for all your guy's help!
 
Not sure what you did here.

Leave the fa 0/0 with dhcp so it get a ip from your gateway router. Then put nat outside on that interface. You want nat inside on all the sub interfaces. The nat statements will nat to the interface with overload.
 
Solution