Solved

Need serious help

Bought a new case came today installed the motherboard inside the case only.problem is nothing powers on only indicators i have are the red lights in the board
Any suggestions?
7 answers Last reply Best Answer
More about question
  1. Things I've tried:

    Removing ram
    Removing CMOS battery
    Running the setup on a box
    Tried 2 power supply's
    Tried the screwdriver in the power switch method
  2. 1) verify that all required (and only required ) standoffs are in place between mobo and case

    2) examine I/O shield and make sure it's fitting correctly (not bent or out of position) and not shorting out the mobo
  3. I have my motherboard on a box still no hope

    Perhaps it could be that i killed the board with static?
  4. Best answer
    Oops - sorry I missed that. Possible, but more likely just a DOA mobo given your other troubleshooting steps.

    Did you doublecheck that the CPU is seated correctly and not damaged?
  5. 1. Make sure everything is seated correctly
    2. Make sure your motherboard BIOS is currently up-to-date
  6. Motherboard was dead got a new one today installed it runs perfectly now thanks for the help guys
  7. Good deal!
Ask a new question

Read More

Power Supplies Motherboards Light CPUs Cases