Solved

Windows 7 installation "No device drivers found" on a new build

I had built a new pc a while ago and installed Windows 10 on it as I can't figure out a solution for Windows 7's installation error, I really don't like Windows 10 and I'd like to clean install Win7 but can't because of this. I open up up the USB from the bios and when I click start installation, it tells me no device drivers were found? I had dealt with this issue before on my old laptop and had it fixed but this seems impossible to fix on this computer. I had searched the internet from top to bottom for a solution but with no success. The iso is definitely not corrupt because I can run the installer from Windows. I tried turning off secure boot, I tried doing the legacy stuff through the bios, I tried inserting it into a USB 2.0 port, and I had basically tried everything. I would really appreciate any new suggestion for this.

Here are my specs:

i5 6600k
16 gb ddr4 3000 mhz
Maximus VIII Hero mobo
GTX 960
1 answer Last reply Best Answer
More about windows installation device drivers found build
  1. Best answer
    you need your boards usb install tool and missing drivers to use for a win 7 usb install on skylake

    examples to look at to start on ?

    http://www.asrock.com/microsite/win7install/

    http://wccftech.com/intel-skylake-remove-support-usb-based-windows-7-installation-platform-specs/

    Mod Edit for Behavior
Ask a new question

Read More

Drivers Devices windows 10 Windows 7 New Build