3T External Hard Drive Is Running But Not Useable All of a Sudden--Help!

All of a sudden, my Seagate Backup Plus 3T hard drive stopped working as an automatic, nightly backup. After being unable to get the Seagate backup software working, I tried using the EaseUS software. Now, the drive is non-responsive. I have tried every solution I could find online. The drive is definitely running and, in Device Manager, my system sees the drive and can ID it as a Seagate Backup Plus drive, but it doesn't show up in My Computer and I can't initialize or format it. I'm on a high-end Windows 10 computer and have also tried plugging the drive (USB) into a tablet and an old XP laptop I have. All recognize the drive and say it is working properly--only it isn't! Tried using Seagate and Western Digital tools-no luck. Tried DISK PART commands in Windows--no luck. Any suggestions other than tossing the drive (and never buying Seagate again)? Thanks.
2 answers Last reply
More about external hard drive running useable sudden
  1. Hey there, Randyk.

    Do you get any kind of errors when you've tried DLG and the manufacturer's diagnostic tool? If it's a backup drive, is it safe to assume that you don't need to recover any of the files that are on it since you've already tried to initialize and format it? What happened when you've tried that?

    I didn't see you mentioning that you've tried with a different USB cable, so if you hadn't done that already, give it a try. Sometimes the simplest solutions might prove to be the right ones.

    Other than that if you are unable to test the drive at all, you could get in touch with the vendor you got it from or the manufacturer and see if you can RMA it, if it's still under warranty.

    Hope that helps. Please let me know how it goes.
    Boogieman_WD
  2. Hey Boogieman: Thanks for your suggestions. Tried both the Seagate and the Western Digital diagnostic tools; neither would work on the drive. Yes, it is a backup drive so I don't care about the data; can always rerun backup. Tried to initialize and format it repeatedly; no dice. GPT attempt gets me "The specified disk is not convertible because the size is less than the minimum size required for GPT disks." Weird, since it's 3T. MBR gets me "The system cannot find the file specified." Unfortunately, it's out of warranty. Any other suggestions would be welcome.
Ask a new question

Read More

Storage External Hard Drive Backup Seagate