Solved

computer locke yup after installing gtx 1050 ti in dell xps 8900 (w/600 watt psu)

issues installing evga dtx 1050ti in dell xps 8900
8 answers Last reply Best Answer
More about computer locke yup installing gtx 1050 dell xps 8900 600 watt psu
  1. MERGED QUESTION
    Question from subkiller4856 : "computer locke yup after installing gtx 1050 ti in dell xps 8900 (w/600 watt psu)"

    subkiller4856 said:
    issues installing evga dtx 1050ti in dell xps 8900


    Hello... Where does it "Lock" at when booting?
  2. Ironsounds said:
    MERGED QUESTION
    Question from subkiller4856 : "computer locke yup after installing gtx 1050 ti in dell xps 8900 (w/600 watt psu)"

    subkiller4856 said:
    issues installing evga dtx 1050ti in dell xps 8900


    Hello... Where does it "Lock" at when booting?
  3. At the Dell splash screen.
  4. Hello... What was your previous video card before this one was installed?
  5. Ironsounds said:
    Hello... What was your previous video card before this one was installed?
  6. My Dell xps 8900 came with a nvidia gtx 745, not a really bad card, but not what I really wanted either.
  7. BTW, driver for gtx 745 is the same driver as for the gtx 1050 ti
  8. Best answer
    Hello... Well you are going from a 700 series to 1000 series Video card... and both are PCIe 3.0 rated B / I would suggest checking with DELL to see if they have a MB BIO's update for compatibility or driver fix for the Nvidia 1000 series Cards... If all other fitting solutions have been tried... Typically hardware ID's must be included or need to be read/understood by the BIO's to communicate with it.
Ask a new question

Read More

Dell Nvidia