Cant access bios

So i have a asus z270e mobo i was abke to get into the bios at the initial powerup with my logitech usb keyboard. Now that win 10 is installed and i have been using the new rig the asus app has a firmware update. I cant access the bios at all now neither with f2 or the del button. So when i try to launch the firmware update its the same issue del and f2 wont work to initialize the bios update. The keyboard lights up fine but it wont respond for the bios. I have seen a few threads regarding this to enable usb legacy once in the bios but i cant get in to do so. Is there a specific usb port i should be using? i dont have a old style keyboard to use. Taking out the mobo battery is that my only option? Thank you.
7 answers Last reply
More about access bios
  1. Tried the above no luck?
  2. Then try removing the battery, power cord unplugged.
  3. Ok i tried the battery. I was able to get to the initial bios screen. I try to proceed bow ibto the actual bios but nothing is responding i tried all the usb ports and cannot get a response cant hit enter or f1 nothing happens.
  4. No other idea, unfortunately, than RMA-ing the board.
  5. ya im on hold with asus now. For some reason the main screen shows 2 keyboards 1 mouse but i cant get the keyboard to work hopefully they can help me. Thanks for the suggestions.
  6. No problem.
Ask a new question

Read More

BIOS USB Keyboards