Solved

No SSD or HDD detection from BIOS or Windows (SATA problem?)

Hi all,
FINALLY got my first buid running (yay!) and have just inserted a flash drive with windows 10 to install onto my SSD- except the SSD doesn't show up.

All parts are brand new from Amazon/Ebuyer, and are as follows:
SSD: Kingston SSDnow300 120GB
Mobo: Gigabyte GA-78LMT-USB3 (Rev 6)
CPU: AMD FX4300 Black Edition (with stock cooler)
Memory: HyperX Fury 8GB DDR3 1600MHz
PSU: Corsair VS550
Case: AvP EL03W Viper Mini Tower
(+ TP Link Network Adapter + Fractal Design R3 120mm Case Fan)

I noticed that the BIOS was originally in IDE mode, so have changed that to ACHI, and have also tried a standard seagate 1TB HDD from my old PC- that isn't detected. Could this be a sata problem?
EDIT: Have left it overnight and whenever it turns on, i always get the following message at POST:
DISK BOOT FAILURE,INSERT SYSTEM DISK AND PRESS ENTER


Have tried taking battery out for 1 min and resetting, have tried both IDE and ACHI modes- still same error. Have tried reformatting the windows install disk and prepping it again but no luck. Could i have some help with this too? :)

Thanks in advance, quick replies would be very appreciated.
1 answer Last reply Best Answer
More about ssd hdd detection bios windows sata problem
  1. Best answer
    - Keep ACHI.
    - Change the SATA port that the SSD is connected to. To see if it's just a bad port.
    Make sure the SSD SATA cable and its power cable are connected correctly. SATA Data cable to SATA port on the motherboard and SATA Power directly to the PSU.
    - Try different cables.

    And "DISK BOOT FAILURE,INSERT SYSTEM DISK AND PRESS ENTER" Just means that your system is not detecting anything to boot from. This is normal in your situation because for some reason no drives are being detected. Unless this is also happening now when you have the flash drive connected with Windows 10 on it?
    If so just make sure the flash drive is 1st on the boot priority, which it should be anyway unless you've changed it.
Ask a new question

Read More

Detection SSD Hard Drives SATA