Low FPS gtx 1060 i5-6600

Hey guys, I recently upgraded my pc from an AMD fx-8350 with a gtx 960 4gb to an Intel i5-6600 with a gtx 1060 ( 2x8 GB corsair vengence RAM). However, I have noticed that in some games my FPS is worse than before, or only slightly better. In H1Z1 im getting around 10-30 fps max not even on high settings, so its unplayable, however before I upgraded my pc i would get atleast 40 fps minimum. On overwatch i used to get around 100 fps on high, now im getting 70fps. I have noticed my gpu usage on h1z1 is super low like 20% but i dont know how to increase it. Also dont tell my its my CPU bottlenecking, there are plenty of benchmarks on youtube with of my specs getting insanely more fps.

things iv tried:
1 DDU, completely uninstalling drivers then installing latest drivers.
2 DDU and install older drivers
3 Nvidia control panel setting prefer maximum performance etc
4 memory diagnostics

please any suggestions are appreciated thanks

Also, im running Windows 10, however before upgrading my pc i was running windows 10 but it wasnt activated, so i had to install windows again
Reply to Robbie1092
8 answers Last reply
More about low fps gtx 1060 6600
  1. Are all motherboard drivers up to date?
    Reply to sizzling
  2. sizzling said:
    Are all motherboard drivers up to date?


    how do i check motherbaord drivers? (i was just wondering are there drivers for i5-6600?)
    Reply to Robbie1092
  3. Go to the manufactures website for the motherboard, there will be many different drivers for various parts of the motherboard.
    Reply to sizzling
  4. Is this a new build or an upgrade? What's your system specs? PSU-Motherboard?
    Did you install "intel chipset drivers"? Have you tried upgrading the Bios/Uefi
    Reply to octavecode
  5. this hasnt done anything to help fps. i just went on h1z1 and still at 20 fps, gpu usage is at 20% or below however cpu usage is maxed out at 100%
    Reply to Robbie1092
  6. octavecode said:
    Is this a new build or an upgrade? What's your system specs? PSU-Motherboard?
    Did you install "intel chipset drivers"? Have you tried upgrading the Bios/Uefi


    its an upgrade. Not exactly sure what psu i have, although i do know that is is very decent. my motherboard is an MSI B150 Gaming M3 ATX LGA1151 Motherboard. could you send me a link on where to get the intel chipset driver for i5-6600. and i dont know what ur talking about when u are asking me if i have tried upgrading bios
    Reply to Robbie1092
  7. octavecode said:
    Is this a new build or an upgrade? What's your system specs? PSU-Motherboard?
    Did you install "intel chipset drivers"? Have you tried upgrading the Bios/Uefi


    when i try to download intel chipset drivers it says my systems doesnt meet the minimum requirements
    Reply to Robbie1092
  8. Reply to octavecode
Ask a new question Answer

Read More

FPS