Solved

Slow SSD - read /write

Hello all,

I am new with respect to knowledge on drives, but after reading a lot - i decided to buy the following products (links below) and was expecting a different result

http://www.amazon.in/Transcend-Portable-Enclosure-Casing-25S3/dp/B00JTNZP0Y?_encoding=UTF8&psc=1&redirect=true&ref_=oh_aui_detailpage_o00_s00
http://www.amazon.in/Samsung-500GB-2-5-Inch-Internal-MZ-75E500BW/dp/B00S17G21K?_encoding=UTF8&psc=1&redirect=true&ref_=oh_aui_detailpage_o01_s00

Could you all please help in identifying the issue? please find the current results using USB 3.0


The disk is cloned from existing mac OS.
Please help me out with it.

Thanks,
Rishi
11 answers Last reply Best Answer
More about slow ssd read write
  1. this is results of an external drive on usb 3 not as you stated an ssd which is not the 500gb ssd
  2. RARRAF said:
    this is results of an external drive on usb 3 not as you stated an ssd which is not the 500gb ssd


    yes the results are for 500 gb SSD only - using the external casing (which is having usb 3.0) . I have mentioned the casing used + 850 evo drive, the results are pretty bad.
    That's why i wanted to know what could be the problem.

    Thanks,
    Rishi
  3. Are you using this external drive enclosure with a Laptop? What is the specific brand and model of the computer? Are you sure you are connecting to a USB 3.0 port on the computer and not a USB 2 port?
  4. mjslakeridge said:
    Are you using this external drive enclosure with a Laptop? What is the specific brand and model of the computer? Are you sure you are connecting to a USB 3.0 port on the computer and not a USB 2 port?



    Yes i am using external drive enclosure with MacBook Air 13" . yes it has only usb 3.0 port and using the same.
  5. Best answer
    well the results are typical of usb 2 even if you had usb 3 speed is only near 100mbs why are you using an ssd in an external case the cables you are using are limiting you an ssd is typically used as an internal storage where you use a sata cable to connect where you will get 500mbs read/write nearly.
    https://www.youtube.com/watch?v=ZqNWYVJqj3E
  6. I would suggest installing the new 500 GB SSD as the primary drive in the Macbook Air, but it looks like it only comes in 2 configurations, 128 GB and 256 GB, so I don't know if if would support the 500 GB. You could try it. As said, using a SSD in an external enclosure is going to limit the speed as opposed to installing it internally.

    http://www.apple.com/shop/buy-mac/macbook-air
  7. RARRAF said:
    well the results are typical of usb 2 even if you had usb 3 speed is only near 100mbs why are you using an ssd in an external case the cables you are using are limiting you an ssd is typically used as an internal storage where you use a sata cable to connect where you will get 500mbs read/write nearly.
    https://www.youtube.com/watch?v=ZqNWYVJqj3E


    Thanks for the help.. :) I reinstalled the fresh mac os and it resolved the issue
  8. mjslakeridge said:
    I would suggest installing the new 500 GB SSD as the primary drive in the Macbook Air, but it looks like it only comes in 2 configurations, 128 GB and 256 GB, so I don't know if if would support the 500 GB. You could try it. As said, using a SSD in an external enclosure is going to limit the speed as opposed to installing it internally.

    http://www.apple.com/shop/buy-mac/macbook-air


    Thanks for the help.. :) I reinstalled the fresh mac os and it resolved the issue and speed test are much better than before.
  9. Glad you got it working well.
  10. I don't know why a fresh install of the OS would make that big of a difference in the read/write speeds, unless you had a virus on the old OS install. But anyway, glad you got decent speeds now. Test it again in a few weeks or so.
  11. mjslakeridge said:
    I don't know why a fresh install of the OS would make that big of a difference in the read/write speeds, unless you had a virus on the old OS install. But anyway, glad you got decent speeds now. Test it again in a few weeks or so.


    Sure i will check and let you know the same later, but thanks for the help. Possible that could be the case or may be wrong drivers in old OS- not sure but right now - its working well
Ask a new question

Read More

SSD Products