Solved

[SOLVED] No screen or display after BIOS update

So I've just updated the BIOS on my MSI H170. I thought everything went fine during the AMI BIOS update, but when the loading bar was at 100% my computer restarted with no screen output. I am now stuck with a USB that contains a new .c90 file to flash, but I can't get a display output to atleast know what is going on. Besides that, I noticed a red LED on the motherboard next to a label 'cpu'. However, all LEDs and components such as fans are working.

Any help is appreciated.

Kind regards,
Jasper
Reply to Polymelon
6 answers Last reply Best Answer
More about screen display bios update
  1. did you do anything other waiting patiently? remove the usb maybe?
    have you tried to clear cmos? since you are updating BIOS I'm assuming yo know you ways around computers.

    things you can try.
    tried to remove and change the cmos battery?
    try a different cpu
    breadboard (reassemble computer)

    if don't work
    your motherboard maybe bad. (I experienced red led near cpu myself.) It was the mobo.
    Reply to Darthutos
  2. Best answer
    first, why did you update in the first place.

    if it made it to 100%, it means it finished. maybe pull the power and the battery or clear the bios with a jumper/switch however you do it on your board.
    Reply to getochkn
  3. Alright I've fixed it myself. To anyone experiencing the same issues, try this:
    - Switch your pc off and unplug the power for atleast 20 seconds.
    - Switch to a direct video output on your motherboard instead of graphics card.
    - Turn your pc on again.
    - If that doesn't fix it: turn your pc off and replug all drives.
    - Pray to Lord GabeN.
    Reply to Polymelon
  4. getochkn said:
    first, why did you update in the first place.

    if it made it to 100%, it means it finished. maybe pull the power and the battery or clear the bios with a jumper/switch however you do it on your board.


    Thank you for your quick response! I fixed it before reading the comments. I tried to update the BIOS for new chipsets and .m drives support.
    Reply to Polymelon
  5. It would have helped me if I was working on an intel system.
    It was an fx 8350 with asus sabertooth mark 2.
    the asus fx 8350 is still running strong on asus crosshair
    Reply to Darthutos
  6. Darthutos said:
    did you do anything other waiting patiently? remove the usb maybe?
    have you tried to clear cmos? since you are updating BIOS I'm assuming yo know you ways around computers.

    things you can try.
    tried to remove and change the cmos battery?
    try a different cpu
    breadboard (reassemble computer)

    if don't work
    your motherboard maybe bad. (I experienced red led near cpu myself.) It was the mobo.


    Thank you for your respone! Apperantly the BIOS update worked, but for some reason the POST failed and didn't use my graphics card's output as a video source at the first boot.
    Reply to Polymelon
Ask a new question Answer

Read More

BIOS MSI-Microstar Motherboards Failed Update