Solved

MSI B250M PRO-VDH Fan Control not working in BIOS

I've just changed my CPU cooler from the boxed cooler to a be quiet! Pure Rock cooler and it seems like I cannot control the CPU or any other cooler via BIOS or SpeedFan.

Bios allows PWM / DC fan control but if I change values here, the rpm of the cooler do not change at all. CPU Cooler is 4 pin, case coolers are 3 pin and for none of the coolers either DC or WPM changes are working at all.

CPU cooler is stuck at ca. 350 rpm, case cooler is stuck at 1150 rpm.

Bios was already updated, I also tried to use SpeedFan but it doesn't allow any changes at all.

Thanks for your help!
7 answers Last reply Best Answer
More about msi b250m pro vdh fan control working bios
  1. If reinstalling the stock cooler, still same issue?
  2. It's quite a task to change coolers and I don't see why this should change anything at all. Can you tell me more? I have not looked into the bios settings when installing the stock cooler but I wasn't able to change anything with the stock cooler in SpeedFan as well.
  3. Have you tested the pc under load and the fan speed does not change?
  4. I've tried to stress it with CPU-Z and there is no noticable difference in the loudness of the fans. I was playing today and also after more than 1 hour cores stay pretty cold (25-30 °C) according to speed fan and also stress tests don't get the CPU too warm.

    Furthermore I've unplugged sysfan 1 and 2 from the mainboard without any noticable changes besides the fact that they both show 0 rpm in the BIOS. Fan speeds both are still running anyway... CPU Fan speed stays the same according to the BIOS. Even tough the CPU fan has a 4 pin WPM plug it is not controllable in any way.

    Due to the size of the cooler I currently was not able to plug both case fans to sys1 and sys2. I only was able to plug either sysfan1 OR sysfan2 to the mainboard but this shouldn't be the problem, right?
  5. No, it shouldn't be a problem.
    Not sure about the issue, though.
  6. Best answer
    Found the reason why it's not working - I've had the SYSFANs attached to Molex AND 3pin. Now it's working fine.
  7. Thank you for the update.
Ask a new question