Solved

PCIe NVMe SSD not working with Z270E

I installed a Samsung 960 EVO PCIe NVMe 250gb SSD into my current build. Device manager sees it and says it is working properly. Drivers current etc. I also installed a Samsung NVMe driver to be safe. I cannot access my ssd anywhere. I have made BIOS changes to try and get the pc to recognize the drive to no avail. It is currently in the m.2_2 slot, though I've tried both. I tried Samsung Magician but it doesnt even pick up the ssd. The event log says disk started and disk initialized, but nothing happens. I used command prompt and did a list disk, this only shows my hdd as well. Im lost? 15 hours later or work in this. What can I do?
Reply to shawnw123
2 answers Last reply Best Answer
More about pcie nvme ssd working z270e
  1. Sorry forgot specs:
    Asus Z270E Strix Mobo
    WD 1TB HDD
    Intel i-5 6400
    Asus Strix GTX1060 6gb GPU
    DVD Drive

    Adding:
    Samsung NVMe SSD 960 EVO 250gb
    Reply to shawnw123
  2. Best answer
    You have to format the drive first. Click on your file tab, find the ssd name, right click it, and there should be a format option, click that, and your good to go!
    Reply to Phaaze88
Ask a new question Answer

Read More

SSD Samsung Device Manager