PC Not switching on (no fans but motherboard lights on)

Hello all

I've got a rather annoying intermiddant problem with my PC, where it doesn't switch on (no fans but power light on motherboard is on) . However can get it start eventually after switching the on/off button on the power supply times multiple times (in many times over 15 times).


The PC itself is 5 years old and has following specs:
- Seasonic SS-1050XM Power Supply
- MSI Z77A-GD65 Motherboard
- Intel i7-3770K (3.5 Ghz) CPU
- MSI Nvidia Geforce GTX980 Graphics card
- HyperX Ram 8 GB x 2 RAM
- 2 X Kingston HyperX 3K 240 GB SSD Drive
- 3 TB Seagate Barracuda HDD


Have filmed it and uploaded it to youtube here:
https://www.youtube.com/watch?v=rEUyOvuFU84

I have tried reseating all the power supply cables with no luck.

Anyways wondering if this is related to power supply or motherboard?

Please advise guys and let me know if you need any further info.

Many thanks :)
4 answers Last reply
More about switching fans motherboard lights
  1. not sure but from your video the PSU is not outputing any voltage because the fans would at least work in my eyes looks as if its a PSU problem to me.
  2. RARRAF said:
    not sure but from your video the PSU is not outputing any voltage because the fans would at least work in my eyes looks as if its a PSU problem to me.


    Thanks for the answer. I'm really hoping it's just a PSU issue but would like to be sure before buying a new one.
  3. RARRAF said:
    not sure but from your video the PSU is not outputing any voltage because the fans would at least work in my eyes looks as if its a PSU problem to me.
  4. After replacing the PSU the problem disappeared. Thanks for the help :)
Ask a new question

Read More

Power Supplies Motherboards