Solved

GPU fans not working properly, what could be the cause?

I think my GPU fans are not functioning properly.

I am using a Sapphire HD7950 Dual-X, 3GB memory with 2 fans. When i boot my pc, both fans spin for about 1 or 2 seconds. In Windows it idles for about 42C and CCC or TRIXX report fan speeds of 10-20%, but when i look at the card, both fans are not moving.

When i set custom fan speeds, the fans work though. Fan 2 only works after i set the speed to 85%, which i think isn't normal, as both fans should be spinning simultaneously at any time. The weird thing is, that fan 1 keeps spinning when i set the speed back to automatic, this gives me a nice idle temp of about 35C.

Could anybody help me to clear out what's causing the issue? I've been reading other threads where many people suggest to unclog and oil the fan. I just took the card out of my PC and the fans are not filthy, and there is no difference between the amount of friction to move the fans around, spinning the fans feels very light.

Anything helpful would be welcome!
5 answers Last reply Best Answer
More about gpu fans working properly
  1. It's a 5 year old card, fans probably died.

    And if you don't clean regularly it can get clogged up.
  2. try doing a clean install of the amd drivers just to make sure it not a driver issue. if the error still there see if the card still under rma warranty.
  3. EpIckFa1LJoN said:
    It's a 5 year old card, fans probably died.

    And if you don't clean regularly it can get clogged up.


    I have bought the card a bit less than 3 years ago, and if the fans would have died, they wouldn't be working at all right? I remove all dust from my case a couple of times each year... Everything is clean and smooth
  4. smorizio said:
    try doing a clean install of the amd drivers just to make sure it not a driver issue. if the error still there see if the card still under rma warranty.


    Just tried this, no results.... Also submitted a ticket to Sapphire, maybe they know a fix
  5. Best answer
    Died or dying. if they aren't spinning as fast as they are supposed to and only respond with stupid high voltages (how fan speed is determined) it indicates dying fans.

    And seeing as how the card released Q4 2012, you either bought used, or you bought a card that was produced years before it was sold.
Ask a new question

Read More

GPUs Fan AMD Graphics Cards