Custom Watercooling Temperatures

So I finally replaced my dying 360mm AIO cooler with a custom watercooling loop. It's the EK 280 kit with a 420mm radiator added in. My question is, my 5820k is still reaching 75°C at 4.5GHz at 1.295V

And my friend says that's too high for custom watercooling?

The Asus Poseidon 1080 Ti doesn't go above 52°C. The fans on the 420mm radiator are EK Vardar F4 140mm fans, top speed of 2200rpms, the fans on the 280mm rad are whatever was included in the kit.
Reply to Potato Joe
7 answers Last reply
More about custom watercooling temperatures
  1. Pictures please.
    Reply to Wizard61
  2. Wizard61 said:
    Pictures please.





    Reply to Potato Joe
  3. Potato Joe said:
    Wizard61 said:
    Pictures please.







    Umm, yikes !!! is this your first water cooling setup ? just so you know for the future, the shorter the tubes, the better.

    Do you have push/pull on the front radiator ? I can see you have just a pull config on the top one, this is ok, but not the best, you'd be better off with a push config, but if you are limited for room then I can understand why you did it.

    Your cables could do with a bot of management there too, you'd be surprised how much this can actually help with temps.

    A very quick sketch up of your original picture, I probably would of done it something like this: http://imgur.com/1HLyVUS
    Reply to Seanie280672
  4. Seanie280672 said:
    Potato Joe said:
    Wizard61 said:
    Pictures please.







    Umm, yikes !!! is this your first water cooling setup ? just so you know for the future, the shorter the tubes, the better.

    Do you have push/pull on the front radiator ? I can see you have just a pull config on the top one, this is ok, but not the best, you'd be better off with a push config, but if you are limited for room then I can understand why you did it.

    Your cables could do with a bot of management there too, you'd be surprised how much this can actually help with temps.

    A very quick sketch up of your original picture, I probably would of done it something like this: http://imgur.com/1HLyVUS


    The fans don't fit on the bottom of the radiator, nor would the screws be able to hold it to the case. The radiator itself barely fits due to thickness. It's already hitting the VRM heatsinks on my motherboard. Because of the radiator, I can't run the CPU power cables behind the motherboard tray.

    Also, no. After countless tests, the only thing that negatively impacted airflow to the point where temperatures increased was literally blocking it completely with filters or such things. Cables have no impact.
    Reply to Potato Joe
  5. Most of this 'temp issue' is probably overclock related. Have you tried dropping the voltage a bit and seeing how stable you are?

    We see a lot of these posts where 'temps are too high' but there are more variables involved than just the cooling loop, such as the overclocking setup in the BIOS.

    Also noticed that one of your tubing bends - the one between the GPU and pump - is somewhat kinked. You know you can use the port on the bottom of the GPU block instead, right?
    Reply to rubix_1011
  6. Potato Joe said:
    The fans don't fit on the bottom of the radiator, nor would the screws be able to hold it to the case. The radiator itself barely fits due to thickness. It's already hitting the VRM heatsinks on my motherboard. Because of the radiator, I can't run the CPU power cables behind the motherboard tray.

    Also, no. After countless tests, the only thing that negatively impacted airflow to the point where temperatures increased was literally blocking it completely with filters or such things. Cables have no impact.


    I have to ask whether your front radiator fans are in a push or pull config because that is a fair amount of dirt on the front on the 240 radiator. If you are running pull on the front then you need to make it a push set up with an additional fan on the back of the case drawing air in. Do that plus fix the hose routing and clean the front radiator and then you can eliminate your cooling system from being the cause of overheating.
    Reply to Wizard61
  7. Wizard61 said:
    Potato Joe said:
    The fans don't fit on the bottom of the radiator, nor would the screws be able to hold it to the case. The radiator itself barely fits due to thickness. It's already hitting the VRM heatsinks on my motherboard. Because of the radiator, I can't run the CPU power cables behind the motherboard tray.

    Also, no. After countless tests, the only thing that negatively impacted airflow to the point where temperatures increased was literally blocking it completely with filters or such things. Cables have no impact.


    I have to ask whether your front radiator fans are in a push or pull config because that is a fair amount of dirt on the front on the 240 radiator. If you are running pull on the front then you need to make it a push set up with an additional fan on the back of the case drawing air in. Do that plus fix the hose routing and clean the front radiator and then you can eliminate your cooling system from being the cause of overheating.




    That is a dust filter. It's filtering dust just like it's supposed to.

    The top radiator is too thick for me to fit a fan on the rear of the case.

    All fans are in pull, which I don't like, but was the only way to get a fan on each part of both radiators.

    And sadly I can't put the voltage any lower while keeping this clock speed stable.
    Reply to Potato Joe
Ask a new question Answer

Read More

Overclocking Water Cooling Cooling